Change canonical URL

  • Author
    Posts
  • #112517

    eveliensanne
    Member

    Hi!

    When trying to link to our blog on Facebook, Facebook actually does not automatically create a link to our homepage but creates a link to the /contact page.

    We checked the FB debug site which says that http://www.sayyestonewadventures.com/contact/ is our canonical URL. I suppose this is the reason why it automatically links through to the contact page instead of to our homepage.

    Is there a way to change the canonical URL and is it a problem for SEO/Google that our canonical URL links to the contact page?

    Many thanks!

    The blog I need help with is sayyestonewadventures.com.

    #112720

    ricardpriet
    Theme Author

    Hi eveliensanne,
    Thank for writing :)

    Yes, it’s true, your og:url is pointing to your contact page instead of your homepage. As it is a WordPress.com configuration and we are not able to do anything form the our side (the theme), let’s add a WordPress.com Staff member to help us with your issue.

    Thanks!
    Ricardo P. from SiloCreativo

    #112722

    kathrynwp
    Staff

    Hi there, I’m looking into this and will keep you posted.

    #112723

    kathrynwp
    Staff

    I think we’ve solved this issue by removing all pages previously set in your Static Front Page settings area, and then clearing the Facebook cache using their debugging tool.

    The correct og:url tag is now showing and the homepage is now linked when you share the site on Facebook.

    #112761

    eveliensanne
    Member

    Hi both, thank you so much for your help!

    #112763

    ricardpriet
    Theme Author

    Fantastic @eveliensanne! Nice to hear it worked.

    Thanks @kathrynwp for your help :)

The topic ‘Change canonical URL’ is closed to new replies.