Blog to display as LIVE DEMO does

  • Author
    Posts
  • #156072
    bngadm1n
    Member

    Hi

    I can’t seem to work out how to get my blogs to display exactly like they do in the LUXURY LIVE DEMO. Is there a specific template I need to apply to each blog?

    I love the way they display on the BLOG landing page and how this translates when you click on each individual blog to read the full thing.

    Please could you provide some direction as to how this is created :)

    The site is not live as it is in the build phase so you won’t be able to look at it but if you have instructions somewhere I could follow that would be great!

    The blog I need help with is: (visible only to logged in users)

    #156140
    emilysuesrq
    Theme Author

    Hello,

    You will first need to create and publish a blog page, and give it a title like “Blog”. Then, go to Customize > Homepage Settings > Posts Page, and select your blog page from this dropdown menu. Save your changes.

    New posts will then automatically display on your posts page, as seen in the demo. Let me know if you need further assistance, thanks!

    Kind Regards,

    Emily

    PS – For basic theme setup instructions, please visit the following page and see the “Setup” tab: https://wordpress.com/theme/luxury/setup

    #156173
    bngadm1n
    Member
    Original poster

    Hi Emily

    Thanks that’s REALLY helpful. Just the column down the right side doesn’t show on my layout now. Can you advise how to go about this?

    We also just want ONE feature blog story to display at a time and the rest to be referenced in the right-hand column, how do I stop it showing all my blog posts in the main body of this page?

    #156191
    emilysuesrq
    Theme Author

    Hello,

    The column on the right side of the Blog page in the demo is actually the Default Sidebar. This can be set by going to Customize > Widgets > Default Sidebar, then adding widgets within this location.

    If you only want one blog post to display per page, you’ll need to set this option by going to Manage > Settings > Writing, then under Blog Posts select “1” Display per page: https://cloudup.com/cBYxvvoPCM0

    I hope that helps!

    Emily

    #156549
    bngadm1n
    Member
    Original poster

    Thanks Emily

    The blog page is still displaying a number of blogs for some reason…i’ll do a bit more hunting on my end as to why.

    Is there a way to have the default sidebar appear on certain pages but not others, without using css to hide it on all the other pages? It is throwing out my full width pages and the layout of my others :(

    #156559
    bngadm1n
    Member
    Original poster

    Hi Emily

    After trying a few more things and contacting WordPress support we have deducted that the theme is depicting the minimum # of posts to display. Can you provide another work around to display only 1 post in the theme’s blog display?

    I have worked out the sidebar using page layout templates.

    #157294
    itsdavidmorgan
    Theme Author

    Hello,

    I apologize for the delay. Emily is on maternity leave with her first child, and this support request slipped through the cracks.

    You could try adding the following styles. This will hide all posts on the first page except the first post:

    .blog .blog-holder {
        display: none;
    }
    .blog .blog-holder:first-child {
        display: block;
    }

    I hope this helps. Thanks!

  • The topic ‘Blog to display as LIVE DEMO does’ is closed to new replies.