widgets refusing to show on front page

  • Author
    Posts
  • #93337

    jaw501
    Member

    Hi again – I’m suddenly having an issue getting widgets to show in the footer of the front page. I placed them there using visibility (only on front page). Yesterday, they were present on the page. This morning, they had disappeared. They do show up, however, if I don’t use the visibility function.

    They also show up as properly placed both in the customizer and in the WP Admin dashboard (appearance – widgets). But they no longer show up in the footer of the front page. Here’s a screenshot of the customizer, showing the widgets kind of blanked out.

    https://theartjunkie.files.wordpress.com/2016/03/customize-global-art-junkie-2016-03-26-23-36-33.png

    (A text widget that I placed in the footer of the Apocalypse Art category page – called Why Apocalypse Art – does in fact show up on that category page footer, as it’s supposed to, using visibility)

    Sorry this is so long winded, but do you have a suggestion? Many thanks.

    The blog I need help with is theartjunkie.wordpress.com.

    #93459

    binarymoon
    Theme Author

    Hi there – sorry to hear you’re having issues with the widgets. This sounds like a wordpress.com issue so I shall ask the wordpress.com team to take a look and hopefully they can fix it for you.

    #93463

    jaw501
    Member

    Oh, dumb of me. Of course it’s more a WP issue. Thanks, appreciated.

    #93470

    binarymoon
    Theme Author

    Nothing dumb at all. Feel free to ask here if you’re not sure. I can always get help if it’s not something I can do :)

    #93487

    kathrynwp
    Staff

    Hi there – looks like your front-page settings aren’t quite correct. You’ve selected “static page” but haven’t selected which page to display either as your static page or your posts page:

    https://cloudup.com/cTlaakvqjPu

    Because you haven’t assigned a specific front page, your homepage isn’t being assigned the correct front-page code that lets the widget visibility tool that it should display specific widgets on the front page.

    If you select “Your latest posts” for the front page your widgets should be displayed. Let me know how it goes.

    #93500

    jaw501
    Member

    Hi Kathrynwp – No, my settings ARE set to latest posts (not static page) and it’s been that way since I changed my theme to Puzzle a few days ago. (I know it’s not the theme)

    And the thing is, the widgets were working on the front page footer beautifully for the first 36 hours or so. I’ve had some weird things going on for a couple of days with http://theartjunkie.wordpress.com and http://canadianartjunkie.com that I was back and forth with WP Support on.

    https://en.forums.wordpress.com/topic/wp-dashboard-issues-this-morning?replies=7#post-2597915

    Late last night, when I cleared my cache for the sixth or seventh time, some of the garble I was experiencing finally was eliminated – and I’m betting it was something on our home network, which has three WP.com blogs on it.

    Anyway, I appreciate your comment, but it still isn’t possible to get those properly placed widgets to appear on the front page of Global Art Junkie with the visibility settings I want. (The widgets do appear on the front page footer when I don’t set a visibility, but that means they also appear in the footer of blog posts, so not what I want)

    #93502

    jaw501
    Member

    OK Kathrynwp, do you have magic? The widgets just showed up on my Global Art Junkie front page. If that was you, thank you so very very much.
    (And if it wasn’t, bless the other angels at WP.com, where I’ve always been impressed that there’s always an answer!)

    #93503

    kathrynwp
    Staff

    Hi Kathrynwp – No, my settings ARE set to latest posts (not static page) and it’s been that way since I changed my theme to Puzzle a few days ago. (I know it’s not the theme)

    That’s weird, as the screenshot was taken directly from your site. :) The setting is now correct:

    https://cloudup.com/c9eP6lq0CSJ

    Let me know if the widget visibility settings work as expected now.

    #93504

    jaw501
    Member

    So if you took that screenshot for static-page directly from my customizer, it’s totally me. I do still use WP Admin, and that’s what I checked when you prompted me about the front page settings. In admin, it was set to posts, but by your screenshot, it was set to static in the customizer? Anyway, I really appreciate your involvement and thanks again.

    #93505

    kathrynwp
    Staff

    Glad it’s working now! I didn’t touch any of your settings, so the magic must lie elsewhere. ;)

The topic ‘widgets refusing to show on front page’ is closed to new replies.