Widgets Not Showing Up

  • Author
    Posts
  • #136153

    Hello, I do not have access to either the Front Page First or Second Theme in my widgets selection. I purchased the theme, so I’m not sure why I only have access to sidebar and 3 footer widgets.

    The customiser tells me that my “theme has 2 other widget areas, but this particular page doesn’t display them.” No matter what page I navigate to, I get that notice. How do I fix this? Thanks for your help.

    The blog I need help with is loudlymagazine.com.

    #136154

    Additionally, how do I create drop-down menus in this theme?

    #136180

    anarieldesign
    Theme Author

    Hi,

    thank you for using our theme.

    Please read more about setting up the theme and widgets in the theme setup info. Here is a direct link to that setup information: https://wordpress.com/theme/didi/setup.

    If you want to make the home page as a static page like in the demo, please read more about it here: Creating Your Front Page – https://theme.wordpress.com/themes/didi/support/. By default, the front page displays your latest posts on a new site. If you don’t want to use blog posts for your homepage you can set up a static front page following this step-by-step guide. Once you’ve created your static homepage, assign it the Front Page template.

    The widget panel will only show widgets that are applicable to a particular page, so if you don’t see the front page widget areas, try clicking on the site’s header image in the display area of the Customizer. This will return the Customizer to the home/front page and the front page widget areas should appear. Before you’ll need to set up your front page as a static page.

    Here you can find all about setting up the menus: https://en.support.wordpress.com/menus/

    Hope this helps.

    All the best,
    Ana

    #136212

    Hi Ana,

    I understand those instructions, but no matter where I click on my website (including the header area), the front page widget is never available to me. Can I add this in using CSS?

    #136218

    anarieldesign
    Theme Author

    Hi,

    I just checked your website and your front page is still blog page, it’s not the static, this is why you can see those widget areas. Please take a look here: https://en.support.wordpress.com/pages/front-page/ and open a new page, call it for example Home and than launch the Site Customizer and click on the Homepage Settings tab on the left. Select the A static page option, then choose your new page from the Homepage drop down. After this you’ll be able to see those widget areas on your home page. Only when you are on the home/static page this widget are showing as they are not applicable for the blog page.

    Hope this helps.

    All the best,
    Ana

The topic ‘Widgets Not Showing Up’ is closed to new replies.