Tracks in incorrect order on global player / featured album / Album pa

  • Author
    Posts
  • #78996

    wpandb01
    Member

    Hello,
    My album tracks are in incorrect order in the global player, featured album module and my album page.
    They are however, in the correct order in the player displayed below the text in the post you see when you click ‘Read more’ (which is the order in which I arranged the play list when I created the audio post).
    How do I fix the global player, etc. so that it displays in the correct order as well?
    Thanks in advance,
    Annie

    The blog I need help with is annieandbern.com.

    #79135

    otjeremy
    Member

    Hi Annie,

    Thank you, I see the issue. I’ll need to forward this to our developers, but I don’t expect there’ll be any issue getting both players to display the tracklist in the same order.

    Thanks!

    #79186

    wpandb01
    Member

    Oh good. Thanks. Just a couple of additional questions then:
    Any idea how long it will take the developers to address?
    Will I need to go through the customisation process again after the change? (I’ve held off continuing with my customisation just in case, but perhaps I should go ahead with it and repeat it if necessary.)

    #79199

    otjeremy
    Member

    Hi Annie,

    1) Hopefully early this week. I will ping them again in a few hours (differences in time zone) to see if they’ve had a chance to look into the setup.

    2) This shouldn’t affect any customizations that you’ve done.

    Thanks!

    #79337

    wpandb01
    Member

    Hi again.
    In addition to the track order problem, I’ve noticed further fundamental problems with the Album theme:
    – The global player is only working on my Home, News (blog) and Albums pages. It displays, but does not work, on my other pages. This includes both pages newly created as tests and those carried over from my previous theme.
    – Audio files embedded into pages, as single tracks or playlists, do not display at all.
    – On adding the Categories widget to my side bar, I found that when I clicked on any of the category links, they went to a page saying ‘Nothing found’.
    I am now considering switching to a different theme, and requesting a refund, unless these problems can be resolved very swiftly. My marketing schedule is being held back because I can’t market a site in which the global player, embedded audio player and categories don’t function properly.
    Could you please tell me when these problems can be fixed?
    – Annie

    #79339

    otjeremy
    Member

    Hi Annie,

    Let’s review:

    1) I’m able to replicate this, but only if I interact with a player on another page, then try to resume the global player. Are you doing the same, or does the player simply stop working for you when you navigate away from the home page?

    2) Do you have posts in the category that you’re adding to your sidebar? This shouldn’t be theme related, as WordPress itself handles this.

    Thanks!

    #79340

    wpandb01
    Member

    Hi,
    1) No, I’m not interacting with any other player. The global player only keeps playing when I navigate between the Home, News and Albums pages (after it pauses for a second or two) but if I navigate to any other page on my site, it stops. Even clicking the play arrow again won’t get it to play.
    2) Yes, there are posts in each of the categories. They used to display in my previous theme without any problem.

    #79341

    otjeremy
    Member

    1) Thanks! There appears to be a jQuery error that is stopping the player. I’ll notify our developers.

    2) If you activate a different theme, for example ‘Twenty Fifteen’, do the links in the sidebar start working?

    Thanks!

    #79342

    wpandb01
    Member

    If I activate another theme, will I lose all the customisation I’ve done to Album?

    #79367

    wpandb01
    Member

    Hi.

    A bit of further review:
    1) Any idea when the developers will be able to fix the jQuery error?

    2) I just previewed Twenty Eleven (my old theme) to see if the Categories widget works in the sidebar, and it does. It’s just not working in the Album theme.

    3) Regarding my query about audio files embedded into pages not working, I’m wondering if they actually only ever work in posts and not ever in pages – I’ve just emailed WordPress support asking if this is the case. Do you happen to know?

    #79369

    otjeremy
    Member

    Hi Annie,

    Let’s review :)

    1) The playlist on the single album page will now display in the same order as the playlist on the home page. This will happen automatically with the theme’s built-in player, but if you’re using WordPress’ audio shortcode, then you may need to edit that shortcode to re-order the displayed track listing (https://en.support.wordpress.com/audio/).

    2) The jQuery errors look like they might be coming from the share buttons on the single album page. Can you try disabling these as a test, to see if the player resumes (we’re trying this and a couple other things on our end as well).

    3) Strange. Categories work in the demo: https://albumdemo.wordpress.com/category/politics/. I’m going to tag WPcom support and so they can check your setup, as I don’t see anything obviously wrong.

    4) Audio should work in posts or pages, but there might be a conflict occurring between the two players. If you remove the audio shortcode from one of the album pages, does the global player start working again on that page?

    Thanks!

    #79374

    wpandb01
    Member

    Hi.

    1) I think you might have misread my very first message: The playlist that appears below the text on the audio-format post (I assume that’s what you mean by ‘single album page’) was in the correct order all along (with Here Comes The Love as the first track). It was the track ordering on the home page and in the global player that was incorrect (with I Like It as the first track). This hasn’t changed. I haven’t used any short code as far as I know. I’ve just followed the instructions in the first section of that same support document that you linked to. Have we got our wires crossed along the way as regards this problem?

    2) I disabled the share and like buttons just now in the album post, but it hasn’t fixed the problem of the global player not functioning on some pages.

    3) I even just clicked on ‘Album’ under ‘This entry was posted in:’ on the album post, and it went to a Nothing Found page as well. I wondered if it might’ve had something to do with categories set up before I switched to this new theme, but evidently that’s not it.

    4) I don’t have any audio shortcode in any of my pages – I took it out yesterday before I replied at 3:57pm. I had tried to insert audio in my Weddings page but when the playlist didn’t appear on the page, I deleted the insertion because it left a blank space on the page.

    #79378

    kathrynwp
    Staff

    otjeremy – I’ve been able to reproduce the empty categories issue on a test site with Album (but not in Twenty Fifteen) so we will put in a ticket for this, please look out for it.

    #79388

    wpandb01
    Member

    Hello,

    I’ve done a bit of testing myself:
    I added a playlist to my Weddings page again and checked that it still appeared only as a blank space in that page.
    I then unselected my album in the Featured Album Module, and found that the playlist appeared – So yes, there must be a conflict between the two players.

    Thank you for your responsiveness and your efforts to solve the problems. Because I need to get my website working as a marketing tool as soon as possible, and because I need to be able to embed players on pages, I’m going to switch to another theme for now and request a refund for my Album purchase.

    – Annie

    #79393

    otjeremy
    Member

    Hi Annie,

    Thank you for confirming (and for your patience). I’ve notified our developers about this, as well as Kathyrn’s findings, so we’ll get on this a.s.ap.

    Thanks!

    #79458

    kathrynwp
    Staff

    Just to close the loop, this issue has been fixed by the developer, though I realize you had to switch to a new theme.

The topic ‘Tracks in incorrect order on global player / featured album / Album pa’ is closed to new replies.