Topics loading out of order

  • Author
    Posts
  • #83733

    Hi,

    despite my posts being ordered by date they will often load in a completely random order which is obviously very annoying. Also, the text on the posts often loads with the generic font rather than the one I have selected.

    Please can we solve this?

    Thanks, James

    The blog I need help with is jamesloveday.com.

    #83911

    angelatcrist
    Member

    Hi there,

    Thanks for reaching out! Hmmm…I have not seen this random order before. Can you point me to an example of this?

    I’ve updated this thread to include the WordPress.com staff, they can touch on the font issue you are experiencing.

    Looking forward to hearing from you.
    Angela

    #83978

    kathrynwp
    Staff

    This theme uses a Masonry grid, meaning that posts are fit together in a way that best makes use of the available space. Perhaps this accounts for what you’re seeing?

    Regarding the font, looks like you’ve selected Minion Pro for both headings and the body font. Could you show me a screenshot of where you’re not seeing Minion Pro so I can have a look?

    Here’s a guide on how to make a screenshot:
    http://en.support.wordpress.com/make-a-screenshot/

    You can upload the screenshot – in a graphic format like JPG, PNG, or PDF – in your Media Library so I can see it. Thanks.

    #84074

    angelatcrist
    Member

    Hi James,

    If you are still need help, see Kathryn’s comments above.

    Have a great day!
    Angela

    #84075

    Hi Angela,

    no the masonry grid isn’t the problem. It is that posts from the very bottom of the 50 posts I’ve made are coming up right on the top and middle and the posts are entirely out of order.

    The font is also not loading properly and I sent through those screen shots for both. These are very basic things that are going wrong and no one has been of any help in fixing them since I got the site in MAY, so I am currently very disappointed in the service I have paid for.

    James

    #84076

    kathrynwp
    Staff

    Sorry to hear you site is still having issues with the post order and the font.

    Post order
    I see that you were recently discussing the “out of order posts” issue with Velda, one of our Happiness Engineers. She’d asked you to try setting your homepage to display fewer posts to see if that helped with the loading order issue, as it wasn’t something she could replicate. She asked you to let her know if that helped, but I don’t see a reply from you after she said “Let me know whether it helps.”

    Angela, has this issue been something that other users of the theme have reported? It

    Fonts
    Could you please clarify what font do you want to use for heading and base font? Is it Minion Pro?

    The last support request I see related to this was from August, when you were discussing the issue with Andrew, and told him you had things sorted out. Were things OK for a while and then your custom fonts stopped loading again?

    Does this happen on every page or just specific pages or posts, and if so could you provide a link to where it most often happens? Have you tried this on a known fast network to rule out a slow network speed preventing the fonts from loading in a reasonable amount of time?

    #84077

    With the post order I think Velda changing the post number did help, however it has seemed like it has on many occasions but has then slipped back to doing it.

    The fonts still flash up with a very heavy, boxy type as shown in the multiple screenshots, but what I really want is minion pro 100% of the time . . .

    Thanks, James

    #84078

    kathrynwp
    Staff

    The fonts still flash up with a very heavy, boxy type as shown in the multiple screenshots, but what I really want is minion pro 100% of the time . . .

    Here’s something you might want to try, as it might be the culprit for what you’re describing so I think it’s worth a shot to see if you notice a difference.

    When we added free Google fonts to all sites across WordPress.com over the summer, we changed the way web fonts are loaded. On slower connections, we used to show a blank page before the content loaded – now, we display the content in the theme’s default font first, so no one sees a blank page. We realize this means that there may be a flash of a different font before the page finishes loading, but we think overall this is better for folks on slower connections than seeing a blank screen.

    This CSS snippet should return your site to the previous behaviour on loading:

    .wf-loading body {
      visibility: hidden;
    }

    Want to give it a try?

    #84079

    kathrynwp
    Staff

    Would it be possible to provide a link to a screenshot in your Media Library of your posts being “out of order” or otherwise not displayed correctly? I’m wondering if seeing what you’re describing in action might provide a clue as to what could be going on. You can grab its URL from the image’s page in the Media Library, and then paste it here. This is where you can find it, for example:

    https://cloudup.com/ca8M7XfrAtK

    #84098

    angelatcrist
    Member

    Hi James,

    Do you still need help? If so, don’t forget to check out Kathryn’s above comment.

    Have a great weekend!
    Angela

    #84101

    angelatcrist
    Member

    I’m going to go ahead and close this thread.
    If you still have this question or have any other questions, feel free to start a new thread.

    Have a great weekend!
    Angela

The topic ‘Topics loading out of order’ is closed to new replies.