Sticky Posts In Categories

  • Author
    Posts
  • #125511

    exposures730787426
    Member
    Original poster

    Hi there,

    I really like your theme! One thing doesn’t seem to work though: I would like to have the homepage layout for a page showing categories or tags – anything the allows me to display not all posts, but only selected posts. This basically does work, but sticky posts are not being displayed twice as big, as they are on the homepage.

    For example, here’s my homepage with one larger, sticky post:
    https://exposures730787426.wordpress.com/

    Here’s the category page, which looks much less appealing:
    https://exposures730787426.wordpress.com/category/uncategorized/

    Am I doing something wrong? Thanks for your help!
    Sascha

    The blog I need help with is: exposures730787426.wordpress.com

    #125664

    jleuze
    Theme Author

    Hi Sascha, you’re not doing anything wrong. That is how the theme is built, it has a homepage template that is different than the archive template for the category and tag pages, so it will look different.

    There isn’t any way to change this on wordpress.com, you would need to use a custom child theme on a self-hosted WordPress site.

    #125680

    exposures730787426
    Member
    Original poster

    Hi, Thank you for your quick reply. Just to make sure, even with custom css this would not be possible? This would improve the template even more, in my view.

    A second question came up – I do not use the widget area in the right column, so this column doesn’t show. This is what I wanted to achieve. However, it seems, the content section is not using all the available space, it still seems to be sized to leave room for the right column, even in full width. For example, the images on this page are „full width“, however, as you can see, they actually are not.

    https://exposures730787426.wordpress.com/2018/02/06/one/

    Not ideal to display photos. Could the content section be changed with custom css to really use all the available space?

    Thanks again for your support, I appreciate it.
    Sascha

    #125739

    jleuze
    Theme Author

    No, it requires a custom template, it can’t be done with just CSS.

    For the single posts, that column is full width, if you had text in there, it would stretch the full width of the column. I’m not sure why the images aren’t full width as well, did you add the full size images when you added them to the post, or are they possibly large or medium instead?

    #125753

    exposures730787426
    Member
    Original poster

    I tried adding them through the media page and directly in the post, but that doesn’t seem to change anything. When adding the image to the post, I do not see any options like „medium“ or „large“.

    I tested this with a very large image as well, just to make sure. I switched to the HTML view in the editor, and the correct, original image dimensions are used. I noticed however, that when I click on the image (in the published post) and select to open it in a new tab, there is an additional parameter added to the image url and a smaller version of the image is displayed:

    https://exposures730787426.files.wordpress.com/2018/02/dbc08958-71bf-487b-9a39-cbcc1777dcca.jpeg?w=690

    That’s what must be happening in the post as well, I assume? Here is the link to the test post again:

    https://exposures730787426.wordpress.com/portfolio/bangkok/

    Let’s get this sorted, I really would like to use your theme!
    Thanks a lot
    Sascha

    #125754

    exposures730787426
    Member
    Original poster

    This does sound very similar, might it be the solution for your theme as well?

    https://en.forums.wordpress.com/topic/images-not-showing-up-in-size-specified?replies=2

    #125766

    jleuze
    Theme Author

    Could you add me to your site so I can take a look at this in the admin?

    #125790

    exposures730787426
    Member
    Original poster

    Sure, I sent you the invitation just now. Thank you!

    #125809

    jleuze
    Theme Author

    I checked and you had everything setup correct on that post.

    That forum post you linked was correct, there is an option to set the media width in there. I set it to match the max width of that column, and that fixed the images:
    https://exposures730787426.wordpress.com/portfolio/bangkok/

    #125817

    exposures730787426
    Member
    Original poster

    Great, thanks a lot!

    #125836

    jleuze
    Theme Author

    You’re welcome!

The topic ‘Sticky Posts In Categories’ is closed to new replies.