Some videos not appearing in Firefox

  • Author
    Posts
  • #4963

    jtravers
    Member
    Original poster

    I have a series of posts, each including a VideoPress video. In Firefox, about half the videos do not appear: just a blank white rectangle, the others are fine. Have latest version of Firefox, 10.0.2 on a latest configured Mac. The problem has occurred on two PCs also running Firefox.

    The blog I need help with is: jtravers.wordpress.com

    #5093

    thelukemcdonald
    Theme Author

    Do you have a link to a specific video that doesn’t show up? Do any video in particular never show up or is it random?

    In the meantime, I’ll try to reproduce this on my end. If at all possible, it’s usually better to have access to a page in which the problem occurs so I can better troubleshoot and see if I get the same results.

    #5094

    jtravers
    Member
    Original poster

    Sorry I didn’t include the link… http://picturesofpd.com/stories/
    The missing videos are consistently the same. It is fine in Chrome, IE and Safari.

    #5105

    pento
    Staff

    Thanks for the link – I was able to reproduce the same behaviour in Firefox.

    Interestingly, the videos loaded correctly when I disabled the 1Password extension – it seems that extension was causing some errors during the page load. You might like to check if you have an Firefox extensions causing errors.

    In order to get all of these videos working, you’ll need to visit the Edit Media page for each video, and ensure the “Display share menu and allow viewers to embed or download this video” option is checked. This will allow all of the videos load the same way.

    #5128

    jtravers
    Member
    Original poster

    Thanks Pento. I checked one of the non loading videos to ‘Display share menu..’ etc and it then appeared, as did ALL the missing videos. I tried reloading the page, emptying the cache and had a strange result. All videos loaded correctly or the problem returned for some. It appears that updating the top, most recent video, affected the others??

    #5129

    jtravers
    Member
    Original poster

    Update: have checked all videos and all are appearing: thanks.

    #5132

    thelukemcdonald
    Theme Author

    Good to hear. I’m going to mark this topic as resolved for now. If the problem continues in the future, do let us know.

The topic ‘Some videos not appearing in Firefox’ is closed to new replies.