social media hover incorrectly displaying

  • Author
    Posts
  • #62910

    miamicopywriter

    I have a background color for hover on my access menu but it does not display correctly behind the social media icon… it is only 36px high instead of 60px high… is there any fix for this? Or somewhere else I can put this icon? Thanks…

    The blog I need help with is miamiwriter.com.

    #63095

    miamicopywriter

    It seems like the only way to make this work is to remove the background hover and make the social media icon itself hover… is that correct?

    #63176

    angelatcrist
    Member

    Hi!

    Thanks for reaching out! It looks like you got the hover color to work for your social media at least what I see within Chrome.

    Please let me know if I missed something.
    I’m happy to help!

    Thanks,
    Angela

    #63180

    miamicopywriter

    Yes, but the background does not hover properly… the only way is to make the icon itself hover which means the other menu items have to be changed to hover that way too…. it also required lessening the padding or there is a stripe

    #63181

    miamicopywriter

    Yes, but the background does not hover properly… the only way is to make the icon itself hover which means the other menu items have to be changed to hover that way too…. it also required lessening the padding or there is a stripe

    #63206

    angelatcrist
    Member

    Hi,

    I’m looking into this further and update you here.

    Thanks,
    Angela

    #63209

    calebsylvest
    Member

    Hi Julie,

    I’m looking at your site, and first let me say your work looks fantastic!

    I believe I know what you are referring to with your questions above, but please confirm. Here is a screenshot of what I believe you are talking about: http://cl.ly/image/3V2a2u042c2M

    And the issue you have with it is this:
    1. The background color behind the social icon is different than the other link colors. In this case it is a darker teal than the “Home” and “IMHO” links.
    2. The same darker rectangle that holds the social icon (G+) is not as tall as the other links.
    3. The same dark rectangle doesn’t change color on hover.

    So, I think I need to clarify why the social icon is different:
    1. The social icons are not actually part of the menu link list, they are their own entity.
    2. So therefore they are styled differently, with a different color background color.
    3. The dark rectangle doesn’t hover because it is not a link, it is a container for the social icon(s), and the social icon(s) are the links (that’s why it changes color when you hover over it).
    4. If you had multiple social icons than they would line up one beside the other in that area, that’s why it’s a little different. Here is an example of another site that has multiple social icons: http://iamjvstvs.com/

    That is how it functions, so I hope there is some clarification. Does what I explained make sense? If so, and now that you know what is going on, what questions do you have?

    #63212

    miamicopywriter

    0. No, I am fine with the search bar being a little darker than the menu in mobile view. It is the same as the top and I think the theme is set up that way.
    1. Yes, the social media icon is not tall enough in the main menu (desktop) and so the background hover behind it is too small. The icon is only 36 px tall. So the only way to fix it would be to have larger icons…but I cannot upload them in wordpress.com
    2. I fixed it by removing the background hover and making the text hover. It is the only way to make them consistent.
    Thanks for the compliment about the site… I love the Gallery theme because it is minimal but powerful… and it has nice design to start with.

    I do notice some weird stuff like the video (vimeo and youtube) show up above the post title instead of below but the wordpress hosted video works fine. Also, the footer widgets are extremely frustrating because they do not line up easily. This is a drag because the footer widgets are so important. But I have posted about he video elsewhere and other people have already brought up the widgets.

    #63228

    angelatcrist
    Member

    Hi Julie,

    I’m glad Caleb got you squared away on the social hover color.
    I’m looking more into your video question.

    Please let me know if you have any other questions!
    Thanks,
    Angela

The topic ‘social media hover incorrectly displaying’ is closed to new replies.