Social icons showing as squares

  • Author
    Posts
  • #160287

    lotsasmilesphoto
    Member
    Original poster

    The social icons at both the top and bottom of my page are showing only as squares, though they display fine in the customize preview. The search icon (magnifying glass) is also just a square.

    This is broken on both Chrome and Firefox and across both Mac and PC. My blog is http://www.bigtinyworld.com.

    How can I fix this, please?

    The blog I need help with is: bigtinyworld.com

    #160309

    designorbital
    Theme Author

    Hi,
    I am able to see Social Icons at both Header and Footer.
    Please see the screenshot.

    https://pasteboard.co/JH3wVSt.jpg

    Please ping me if i am missing something.
    I am viewing your blog in Google Chrome.

    Thanks

    #160317

    lotsasmilesphoto
    Member
    Original poster

    Thank you for taking a look, @designorbital. Could it be an issue with having a poor internet connection? (my internet here is absolutely terrible)

    No matter the device or browser I use, I cannot see the icons; I see only squares. I’ve also tried incognito mode, desktop and mobile. The only consistent element is my awful internet service here. I even tried LTE, but that’s also really bad here.

    I would think if my page can still load the much larger images, it should be able to handle small icons, but perhaps they’re timing out on weaker connections?

    #160320

    lotsasmilesphoto
    Member
    Original poster

    To follow up on my last note, I had my sister also test my homepage, and she likewise sees squares. She has excellent internet connectivity.

    I’m happy to provide any kind of Inspect or Page Source code if that would help troubleshoot. I’d really love to fix this, as I’m more and more convinced most visiting my site are seeing squares instead of social/search icons :(

    #160337

    designorbital
    Theme Author

    Hi,

    I have rechecked the source and found that Font Awesome css file is not loading. It was previously showing fonts at my local system.

    File is also broken in other browsers.

    Console Error ?

    https://pasteboard.co/JHsAZIR.jpg

    
    Mixed Content: The page at 'https://bigtinyworld.com/' was loaded over HTTPS, but requested an insecure font 'http://bigtinyworld.com/wp-content/themes/anemone/fonts/fontawesome-webfont.woff2?v=4.5.0'. This request has been blocked; the content must be served over HTTPS.
    

    Before going to tag WordPress happiness engineer. Please follow the debug steps,

    1. Deactivate plugins one by one and check the issue is resolved or not.

    Deactivating plugins one by one will help to find the plugin which might be causing this issue.

    Cross Check

    This issue is not seen on Anemone Demo site.

    https://anemonedemo.wordpress.com/

    Waiting for your response.
    Thanks

    #160975

    lotsasmilesphoto
    Member
    Original poster

    Thank you so much for responding. The notification of the response went to my junk folder for some reason, so I didn’t see it right away.

    I tried deactivating a few plugins and noticed the icons were showing correctly. So I reactivated the plugins one-by-one to see which broke them.

    However, I got back to having all plugins activated, and I still see the icons. So… either something changed to where there’s no longer a conflict, or it’s an intermittent issue. If it happens again, I will try to isolate a plugin conflict.

    Until then, I guess it’s fixed :)

    Thanks again!

The topic ‘Social icons showing as squares’ is closed to new replies.