Slideshow block is shaking

  • Author
    Posts
  • #161963

    shinomiura
    Member
    Original poster

    The screen is shaking when slideshows are added in a “column” block.
    (It happens on Windows10, Chrome and Firefox. Mac seems fine.)
    The captured videos are uploaded here/
    https://art-kokura.com/wp-content/uploads/2021/03/bug_editscreen_shaking.mp4
    https://art-kokura.com/wp-content/uploads/2021/03/bug_userscreen_shaking.mp4

    I have already reported the bug to WordPress.com Support.
    I also found the page (only in Japanese) which refers similar case.
    Is there anything to improve in the theme side?
    https://ja.wordpress.org/support/topic/%E7%B7%A8%E9%9B%86%E7%94%BB%E9%9D%A2%E3%81%AE%E3%83%96%E3%83%AD%E3%83%83%E3%82%AF%E3%82%A8%E3%83%AA%E3%82%A2%E3%81%8C%E6%8F%BA%E3%82%8C%E3%82%8B/

    Thank you in advance!

    The blog I need help with is: art-kokura.com

    #162006

    tarasdashkevych
    Theme Author

    Hi,
    First of all, thank you very much for creating screencasts! There are very helpful to see the issue.

    Also, thank you for reporting the issue to a WordPress.com core team. We can cleasrly see that this is a WordPress.com (Jetpack) core specific issue because the issue appears in the Block editor as well.

    I can see that the issue is marked as resoled in the support forum at WP.org. Have you able to fix this issue on the theme side?

    If not, could you please post a link to the page where this issue appears on your site, so I can inspect it and see if there any temporary solution to prevent it?

    Kind regards,
    Taras

    #162023

    shinomiura
    Member
    Original poster

    Hi

    Thank you for your reply.
    The issue still appears.

    https://art-kokura.com/%E9%9D%9E%E5%85%AC%E9%96%8B%EF%BC%9A%E6%9D%BE%E6%9C%88%E4%BA%AD%EF%BC%88%E4%BB%AE%EF%BC%89/

    (You can open the page with the pw “ahkokura”)

    It appears on the block of:
    2-column and 3-column block with slideshows.

    Thank you in advance for your investigation.

    Warm regards,

    #162036

    tarasdashkevych
    Theme Author

    Thank you for providing a link.

    I can see the issue. Also, I want to note that the issue happens on Macs as well.

    It looks like the issue is caused by the block’s JavaScript functionality which tries to calculate a position of the slideshow(s). I hope a WordPress.com team will provide a fix soon.

    Temporary solutions:

    1) Have you tried to disable an auto-rotation in your slideshows to see if it resolves the issue?

    2) Also, we can try to disable lazy-loading for the images shown in the slideshow block to see if it resolves the issue. For this, we need to use a custom code snippet:

    
    /**
     * Exclude specific images from lazy loading.
     */
    function artkokura_jetpack_exclude_class_from_lazy_load( $classes ) {
        $classes[] = 'wp-block-jetpack-slideshow_image';
    
        return $classes;
    }
    add_filter( 'jetpack_lazy_images_blocked_classes', 'artkokura_jetpack_exclude_class_from_lazy_load', 999, 1 );
    

    You can use this free plugin for adding custom code snippets to your site: https://wordpress.org/plugins/code-snippets/

    Hope this helps. Please let me know if you have any additional questions.

    Kind regards,
    Taras

    #162612

    shinomiura
    Member
    Original poster

    Sorry for late reply.
    Your advice worked well, the trembling has stopped successfully.
    Thank you very much for your appropriate solution.

    Warm regards,

    #162618

    tarasdashkevych
    Theme Author

    Hello,

    Thank you very much for confirming that a solution from the previous post has resolve the issue. I am glad to hear that it worked well :)

    Kind regards,
    Taras

The topic ‘Slideshow block is shaking’ is closed to new replies.