Removing comments field on new pages

  • Author
    Posts
  • #23368

    How can I remove all comments fields on new pages e.g. my About page?

    ray

    The blog I need help with is: (visible only to logged in users)

    #23506
    thresholdimpact
    Member
    Original poster

    (I have the CSS upgrade)

    ray

    #23509
    thresholdimpact
    Member
    Original poster

    The blog I need help with has a new name – http://thresholdimpact.wordpress.com/

    ray

    #23512

    Hey there,

    Thank you for your question. I’d be happy to help.

    I would do this with some CSS:

    .page-id-2 #comments, .page-id-2 #comments-reply {
    display: none;
    }

    Hope this helps!

    Kind Regards

    #23529
    thresholdimpact
    Member
    Original poster

    For my other 3 pages do I cut and past this CSS with the number 2 replaced by 1, 3, and 4? (I tried this and it appears to have removed the comments on the Copyright and Legal notices page (the footer page) but not the “About” and “Our Team” pages…very confused by why this wouldn’t change all of them the same way?)

    And, how do I remove comments from posts? I have comments disabled in my Settings/Discussion – but some posts have comments enabled despite this…how do I turn off comments (and remove the “comments closed” line) on existing posts? Will all future posts not have comments now that I have the Settings/Discussion set to not enable comments on posts?

    ray

    #23530
    thresholdimpact
    Member
    Original poster

    Figured it out – was able to remove comments on both pages and posts via the Quickedit functionality for both complete lists.

    Resolved – thanks for your help!

    ray

    #23531
    thresholdimpact
    Member
    Original poster

    Actually – not quite resolved I still have a “comments closed” appearing on posts – how do I remove this reference to comments entirely?

    The comments seem to have entirely disappeared from the pages now…not sure what changed there!

    ray

    #23563

    Hey again,

    If you’d like it everywhere try this:

    #comments, #comments-reply {
    display: none;
    }

    Thanks!

  • The topic ‘Removing comments field on new pages’ is closed to new replies.