Remove links from photos in gallery

  • Author
    Posts
  • #39524

    akswong
    Member

    In the following post: http://cakediem.com/2013/02/24/brownie-recipe/ I have a square tile gallery that I want to set so the photos are not linked to anything. Yet when I set the gallery settings ‘Link to: None’ the photos still seem to be linked to their respective attachment page.

    WordPress staff have advised me this is a problem with the theme.

    Thank you.

    The blog I need help with is cakediem.com.

    #39669

    thelukemcdonald
    Theme Author

    Do you have a link to your conversation with the WordPress staff? I haven’t had a ticket submitted by them stating this is a problem.

    Meanwhile, I’ll test adding a gallery and not linking the images.

    #39706

    akswong
    Member

    The conversation is set to private so I doubt a link would work. However I only received one reply to my enquiry (basically the same one I sent you):

    Howdy Amy!

    This looks like an issue with the theme. I suggest you contact the developers of the theme directly, here:

    https://premium-themes.forums.wordpress.com/forum/debut

    They should be able to help you with this. Do let me know if that helps or if you need help with anything else on your blog.

    Cheers!

    Saurabh

    #39726

    thelukemcdonald
    Theme Author

    Interesting, I don’t see anything in the theme that would be affecting how this functionality.

    After doing a bit of testing, I’ve found the issue to be with the WordPress tiled galleries and/or full-size carousel functionality. These options can be enabled/disabled via Settings > Media > Gallery Options.

    To test, I used the Twenty Twelve theme (a WordPress default theme). I then added a gallery with the “Link to” option set to none. When the tiled galleries and full-size carousel options were un-checked, the gallery images displayed and did not link as expected.

    When you enable tiled galleries, you’ll find the gallery images now link to the attachment page. This is what you are experiencing.

    When you enable full-size carousel, the gallery images link to a carousel display.

    That said, I’ll follow up with the WP.com team to see if what I’ve found to be true and if it’s intentional or possibly a bug.

    #39735

    akswong
    Member

    Strange, as I’ve had the tiled galleries and full-size carousel options un-checked for pretty much the entire time I’ve had this blog.

    I tried clicking these settings on and off to see if it made any difference at all… It did not.

    #39874

    thelukemcdonald
    Theme Author

    The related posts shown below “You may also like:” are displayed in a tiled gallery. I’ve confirmed with the WP.com team that tiled galleries will always link to the image attachment page or Carousel image page. This is a WP.com feature and it’s not possible to change the way it works.

    #39879

    akswong
    Member

    Okay, thanks. It seems odd that there is a no link option displayed in these galleries. Oh well. Thank you for your help.

The topic ‘Remove links from photos in gallery’ is closed to new replies.