Related posts with image not displaying

  • Author
    Posts
  • #87476

    snowmads
    Staff
    Original poster

    Hi! I’m helping someone with her site at nicolecaldwell.com.

    She’d like her related posts to display below her post content, along with the featured image from that post. It’s enabled in her Reading settings, but not displaying on her posts. Is it because the theme has a built-in related posts feature that’s overriding WordPress’?

    #87579

    philip
    Theme Author

    Hi there,

    No. Take a look at: https://creativeportfoliodemo.wordpress.com/2015/01/16/chat-post/.

    You can see the related posts there. Which URL are they not showing up on? If it’s a post or page, then make sure she has them turned on (I think you already did that).

    Let me know where they aren’t showing up specifically and I might be able to dig into this some more; otherwise you may need to ping someone on the theme team to hop into the back-end of the site and make sure the user’s settings are okay!

    Cheers,
    Philip

    #87615

    snowmads
    Staff
    Original poster

    Thanks, Philip! I don’t see it displaying on any of her posts. Here’s an example:

    http://nicolecaldwell.com/2015/12/04/laguna-beach-family-lifestyle-photographs/

    Could it be because there’s no/too little text in the post – only photos? She’s using the Standard post format and the settings appear to all be turned on in her site to allow it to appear. She also has categories set up.

    Thanks!

    #87623

    philip
    Theme Author

    @snowmads, this is really hard to answer without seeing the backend. Here are the settings on the demo site: https://cloudup.com/cw0RP5ojX2K

    And here’s the post: https://creativeportfoliodemo.wordpress.com/2015/01/15/standard-post/

    Can you double-check those settings, and make sure that they are indeed saved? If they are, I’m at a complete loss as to what may be causing this, because I’ve run a couple of tests and it seems to be fine? (Try creating a new Draft post and seeing if they come up.)

    Cheers,
    Philip

    #87624

    snowmads
    Staff
    Original poster

    Thanks, Philip – I am at a loss too! I double checked the settings and they are the same as your screenshot shows, and did a test post using some text. Related posts still did not appear. I will ask our team to take a second look and will get back to you. Thanks again!

    #87657

    philip
    Theme Author

    Thanks so much @snowmads. Let me know what you come up with.

    Cheers,
    Philip

    #87686

    snowmads
    Staff
    Original poster

    Hi Philip!

    Just an update on the related posts not displaying: I spoke to our theme team and they seemed to think that for the system to understand if posts are related, at least ten of her posts need to have a minimum of 100 words of text in the body of the post.

    Relatedness of the post currently takes into account the post title, content, tags and categories. They think that once she has that baseline amount of text, there may be enough content in the others (beyond those ten) to show them as related, but she may also have to add text to those as well. Having alt tags in images and categories helps, but may still not be enough.

    Thank you again for your help, and maybe this will help someone else in the future!

    Best,
    Kristin

    #87707

    philip
    Theme Author

    Hi Kristin,

    Thanks so much for the update. I definitely did not know this and will put this into my support arsenal for future issues that may come up. Thanks again!

The topic ‘Related posts with image not displaying’ is closed to new replies.