Posts overlapping on main page

  • Author
    Posts
  • #142291

    My blog posts are overlapping on my main page and I am not sure how to fix this permanently. If I refresh the screen, it will fix it, but I don’t want people to have to deal with that. Thank you!

    The blog I need help with is courageouslyu.com.

    #142376

    scottrrollo
    Theme Author

    Hey there! This is a really strange issue 😀

    Where are you noticing this? Is it in a particular browser? Does it only happen when you click something specifically?

    Let us know as much as you can so we can take a closer look.

    Thanks!

    #142417

    I don’t notice it on my iPad or phone, but I do on my Mac desktop and laptop. The posts will overlap.

    #142504

    I don’t meant to rush this, but I am still struggling to fix this issue and its upsetting. If there was a way to show you screenshots, I will. I updated my computer and the issue still persists.

    #142522

    scottrrollo
    Theme Author

    Hey! So sorry about this!

    I cannot recreate this issue on our demo website but I can see the issue on your website in the latest version of Chrome for Mac.

    I’ve asked one of the WordPress staff to look into this for you. Hopefully they’ll get back.

    Have a great weekend!

    #143258

    Bonjour, j’ai le même problème sur le site https://ressources-magazine.com/

    #143323

    scottrrollo
    Theme Author

    Thank you! 👏

    I just checked your site using Safari and Chrome for Mac and cannot see the problem you’re describing. Is this problem visible all the time or just sometimes?

    And, can you please let me know which browser and what version you’re using?

    Thanks!

    #143330

    Hello, as explained to WP support who also noticed the same problems, the “anarchic” display on the homepage occurs on all browsers. Personally I use Chrome 74.0.3729.131 (Official Build) (64 bits) for Mac.
    There is both an overlap of articles in the feed but also different spaces between contents on the grid.
    See the screenshots : https://ressources-magazine.com/wp-content/uploads/2019/05/Capture-d’écran-2019-05-03-à-11.49.51.png
    and : https://ressources-magazine.com/wp-content/uploads/2019/05/Capture-d’écran-2019-05-04-à-08.55.00.png

    Thank you for your intervention.

    #143558

    scottrrollo
    Theme Author

    Thanks so much for sharing! I’ve asked our developers to take a look at this and we’ll get back to you as soon as we’ve worked this out.

    Sorry about this! I hope we can squish this bug quickly for you.

    #143565

    Hello,
    Thank you for your feedback.
    I hope he can find the solution because my client comes back to me every day…
    If you need to know the wp plugins used for the site, let me know.
    Have a good day

    #143808

    scottrrollo
    Theme Author

    Hey again!

    We had a close look into this problem and we can’t recreate it on our own website. This leads us to think it’s probably a plugin conflict.

    Out of interest, if you disable all other plugins for a moment, does that helps?

    Let us know 😀

    #143811

    Bonjour,
    merci pour votre travail. J’ai finalement trouvé d’où vient le problème, ce qui peut vous être utile si d’autres utilisateurs rencontrent le même problème :
    Il y a un conflit avec une fonctionnalité de Jetpack. Dans l’onglet “performance” des réglages de Jetpack, il faut désactiver le “chargement optimisé des images”.
    J’espère que mon expérience pourra servir d’autres utilisateur.
    Comme Jetpack est une extension appartenant à Automattic et installée par défaut, peut-être devriez-vous mettre une petite alerte sur votre page de présentation du thème ?
    Bonne journée.

    #143962

    scottrrollo
    Theme Author

    Oh! Thanks so much for help us with this, @ressourcesmagazine 👏

    And great work find the problem. We’ll see how we can fix this for other users.

    #143966

    Glad to have served. Unfortunately, I think there are other incompatibilities with Jetpack….
    I have a new problem on the home page of our site. While trying to explore the Jetpack settings in “theme improvement”, I wanted to test an option for infinite scrolling, but this removed the reload button and there are only 6 items on the home page. I wanted to fix it but I have this error message : “unexpected token <In JSON at position 0>.
    I wrote to the wp support. They told me that they were investigating. I am waiting for the problem to be solved….
    If you have an idea, don’t hesitate!

    #144115

    scottrrollo
    Theme Author

    Ah, okay! Please keep us posted with WordPress’ reply.

    Oxford is compatible with Infinite Scroll, so I suspect something might be conflicting on your site specifically.

    Let us know when you hear back from them! Thanks.

    Have a great weekend 😀

    #144121

    Hello,
    Here is their answer (and finally we came back to the original situation with the load more button):

    “Lae (Automattic)
    May 22, 13:59 UTC

    Hi There!It seems that indeed the theme is currently incompatible with that feature.

    We already reported this to the theme developers, however there is no time frame to solve this. We will send you an update as soon as we have further news on this – however if you do want to use the Infinite Scroll you’ll need to change themes or wait for a resolution.

    Another option is to add a Load More button at the end of the Posts page as shown here: see screen shot

    https://cld.wthms.co/1nKI5y

    Let us know if this option would work for you – we can send you the directions if you’d like :)”

    #144298

    scottrrollo
    Theme Author

    Got it! We’ll investigate this further.

    Is there any reason you can’t use the ‘Load More’ button that Lae recommended? I think that’s a great way to handle this.

    Let us know 😀

    #144302

    Hello,
    that’s what we did.

    #144579

    scottrrollo
    Theme Author

    Okay, good! I just wanted to double-check 😀

    Is there anything else I can help with?

The topic ‘Posts overlapping on main page’ is closed to new replies.