Posts On Home Page Not Displaying Properly

  • Author
    Posts
  • #127949

    chrispageonline

    Hi,

    Could I ask for some help please?

    I have recently added a Tumblr video post to my blog, for reference it’s titled Week 27: Motion Mandala (posted today, the 28/03/2018) and I have noticed it has affected the way other posts are displaying on the Home page, and by that, I mean they are not stacking correctly with the right spacing. Could someone please look into this?

    I currently have the Personal wordpress plan, I’m prepared to upgrade to Premium if this requires CSS code.

    I really appreciate your time and help with this, thank you!

    The blog I need help with is christopherpage.online.

    #128164

    scottrrollo
    Theme Author

    Hey there, Chris šŸ‘‹

    I just checked out your website and cannot see any issue with the layout. Are you still seeing this problem? Could you share a screenshot so we can look into this closer for you?

    Also, out of interest, do you see this problem when you’re signed out of your site?

    Thanks!

    #128192

    chrispageonline

    Hello Scott,

    Thank you for getting back to me. Here’s the screenshot:

    https://amorphixblog.files.wordpress.com/2018/03/screen-shot-2018-03-29-at-11-15-12.png

    Can you see there is a big gap underneath my video post titled ‘Taking Someone To Court’?

    It is not working when I am signed in or signed out, and I am using Chrome. Firefox and Safari also display the same problem.

    I feel it is the Tumblr embed code which is causing the problem (as it creates a small border around the post) but I could be wrong there.

    Thanks for looking into this! Feel free to let me know if you need anymore information.

    #128217

    scottrrollo
    Theme Author

    Thanks for that, Chris!

    This is an interesting little bug. I suspect it must be caused by the way our code calculates the height of each post. If I refresh your website many times, I can actually see the spacing issue in your screenshot. Usually, though, I see it working fine (see screenshot).

    Out of interest, what happens when you refresh your website many times? And, what happens if you temporarily remove that Tumblr post?

    Sorry this isn’t an easy fix! Fingers crossed we can get it sorted soon.

    #128225

    chrispageonline

    Thanks for getting back to me Scott,

    Ah yes I’ve just realised, it seems to be an intermittent problem. It’s working sometimes for me too, and yes if I hit refresh a few times, it stops working, and vice versa.

    I’ve temporarily removed the post, and same issue, I am certain it’s the Tumblr embed that’s causing it, as everything else I have published to the site works fine.

    I can appreciate this might be a tricky one, thanks for your patience and time looking into this! Thank you.

    #128226

    chrispageonline

    Scott, this screenshot may also be of use to you:

    https://amorphixblog.files.wordpress.com/2018/03/screen-shot-2018-03-30-at-11-02-06.png

    I’ve just upgraded to Premium, because I wanted to try and add a video directly to WordPress to see what it does. And in doing so, it changed my theme back (which I’ve now fixed), but in doing so, it shows the problem with the dots in the middle of the page. If you look at the spine of the homepage, the post dots don’t line up, it’s almost as if it thinks there’s additional post that isn’t really there.

    Hope this helps!

    #128259

    tomthethemefoundry
    Theme Author

    Hey Chris šŸ‘‹

    We had a closer look now and it looks like setting a fixed height on Tumblr embed may help. Would you mind adding the following CSS snippet in?

    .embed-tumblr {
      height: 405px;
    }

    Let us know if that did the trick! šŸ™‚

    #128260

    chrispageonline

    Hi Tom,

    Thanks for getting back to me!

    This code appears to have fixed the problem, and is a good backup for if anything goes wrong in the future. I did a bit of experimenting myself, and I realised uploading the video directly to WordPress works better, and then providing a link to Tumblr instead. But know that your work’s not been wasted, as I may have to use this code again, thank you very much for all your help guys.

    Hope you had a good easter, and I hope you have a great week ahead!

    #128261

    tomthethemefoundry
    Theme Author

    Sounds good! Glad it worked, Chris! šŸ‘

    Have a wonderful week šŸ™‚

The topic ‘Posts On Home Page Not Displaying Properly’ is closed to new replies.