Post is not displayed

  • Author
    Posts
  • #18983
    nmhammersen
    Member

    Hello,
    I created a website using the minimum theme. The homepage is a static page, articles should appear on the page “blog”.
    Today, I published the first post. When I click on “preview” everything looks fine, when I go to http://nmhammersen.com/blog/ the post is not visible. The problem is exactly the same when the home page settings are set to “your latest posts”.
    Any idea?
    Regards, Nick

    The blog I need help with is: (visible only to logged in users)

    #19092
    sillyandrea
    Member

    Create a Page called blog. This creates the right /blog/ permalink.

    On the right side of the page, in the Edit Page window, click the drop-down for Page Templates.

    Select the Blog Page template.

    #19102
    nmhammersen
    Member
    Original poster

    I already have a page called “blog”: http://nmhammersen/blog/. Under “Page Attributes” I selected the Blog Page template.

    Result: NO change! The posts are NOT displayed.

    #19111
    sillyandrea
    Member

    Under Settings -> Reading, what do you have selected?

    #19114
    nmhammersen
    Member
    Original poster

    Reading settings: Front page displays “a static page” (Front page: “Ueber uns” / Posts page: “Blog”).

    I already mentioned in my first message that the home page is a static page and articles should appear on the page called “Blog”!

    #19115
    sillyandrea
    Member

    / Posts page: “Blog”).

    And that is the problem. :) The template does the work here – not the settings.

    Please change that setting to no page.

    #19125
    nmhammersen
    Member
    Original poster

    Thank you! That solved the problem.

    As far as I can see, this was not mentioned anywhere (“If the front page is a static page, the setting for posts page must be ‘select’ (no page).”). For people familiar with other wordpress.com themes this is a bit confusing.

    Regards from Germany, Nick

    #19152
    sillyandrea
    Member

    Sorry, wasn’t mentioned as that setting is turned off by default on a new WP blog. :)

  • The topic ‘Post is not displayed’ is closed to new replies.