No Shows = No Homepage Content

  • Author
    Posts
  • #76529

    I can only get the homepage content to appear when I have at least one post in the “shows” category — in my case the category is labeled “events”. When there are no posts in the “shows” category, the homepage content does not appear. (I am using the homepage template.)

    I would prefer a behavior that does not require posts in the “shows” category in order to display homepage content.

    Also, the record icon that appears above the homepage content… is it possible to remove that?

    re: http://jsepperson.com

    The blog I need help with is jsepperson.com.

    #76639

    otjeremy
    Member

    Hi John,

    It looks like you have your featured album (and player), featured page, and footer content setup. The only content that should not show on the home page if there are no shows published, is the featured shows section — so this is to be expected, and is the behavior you’re experiencing from what I can tell.

    I’m assuming that you’re referring to the equalizer icon above the ‘New Website’ text? That can be hidden with the following CSS:

    .home .module .icon {
        display: none;
    }

    Please note that you will need the ‘Custom CSS’ or ‘Custom Design’ add-on to tweak the styling of your theme.

    Thanks!

    #76644

    I am referring to the “Homepage content module”, which is set to on. And the homepage content is not displayed unless there is at least one published show. When there are no published shows, the homepage module content will not display.

    #76645

    I just published a show so that you can better understand what I’m talking about. Sure enough, the content is now displayed. I feel that the homepage content should display even when there are no events in the show category.

    #76647

    otjeremy
    Member

    Hi John,

    Thanks for clarifying :) Can you confirm that you have the following two options set in your theme’s customizer: https://cloudup.com/cs6b8np76br (the ‘Featured Page’ and ‘Featured Posts’ module should display, even without shows, if a specific post and page is selected — your options may be worded differently, so just keep that in mind).

    If you have both options set and it still isn’t showing then I’ll pass this along to our other developers. I don’t imagine there would be any problem with making this change to the theme.

    Thanks!

    #76648

    I am using this theme through WordPress.com and I do not appear to have those options or I am looking in the wrong place. I’ve posted a screenshot here: http://jsepperson.com/2015/05/23/otjeremy-screencap-of-options/

    #76649

    otjeremy
    Member

    Alright — I’m going to talk with our developers and then unless there’s an issue, we’ll get an update for this pushed out. It is the weekend, so I would only expect this over the course of the coming week.

    Thanks!

    #76650

    Great support, thanks! I would love it if this were resolved before my 14 day WordPress premium trial expires. That’s in 13 days…

    ;-)

    #76655

    otjeremy
    Member

    Noted ;)

    #76714

    otjeremy
    Member

    Hi John,

    We’ve comitted a fix for this, which will show once it’s reviewed. I’d expect by tomorrow at the latest.

    Thanks!

    #76719

    Looks good! Thanks for the quick turn around and great service.

    #76724

    otjeremy
    Member

    Happy to help :)

The topic ‘No Shows = No Homepage Content’ is closed to new replies.