Mobile

  • Author
    Posts
  • #132155

    I am trying to troubleshoot an issue with my Dynamic News-based WordPress.com site not displaying properly on some mobile devices. When I load the site on my Galaxy S9 in Chrome or Opera and on iPhone 6s in Safari, the pages load using the default WordPress.com mobile theme – I have to click a link at the bottom of the screen that says “display full site” to see the “rich” content.

    According to WordPress.com’s help page, this should not be happening, as DN is supposed to be classified as a “smartphone ready” theme: https://en.support.wordpress.com/themes/mobile-themes/.

    More troubling, some of my colleagues have phones that display the mobile theme AND refuse to update to the rich theme, even when the “view full site” link is clicked.

    And that wouldn’t be a problem for me, either, except that most of my front page content – including the parent menu and all main stories – disappear when WordPress.com’s default mobile theme version is active. All viewers of the mobile theme can see is the title, a search bar, the hamburger menu with links corresponding with the social media menu, and the sidebar content – everything else is stripped and there is no way to navigate to it (because the menu disappears).

    I do have a little bit of custom CSS, to change some background items, but nothing that I can see would be impacting display of the mobile theme.

    Finally – yes, the help page I linked to does appear to provide instructions for turning off the mobile version – but I can’t seem to find this on my wp-admin dashboard (there is no “mobile” option listed under “customize.”)

    Does anyone know of some way I can turn off the mobile theme on a WordPress.com site, or at least modify the mobile theme CSS so it displays the full menu and main page content when viewed on an “older” phone?

    The blog I need help with is yournorthwestforests.org.

    #132158

    * Sorry, the social media menu does not display as a hamburger menu – it’s a drop-down menu.

    #132193

    themezee
    Theme Author

    Hi there,

    Thanks for using Dynamic News.

    You should be able to deactivate the mobile theme on https://yournorthwestforests.org/wp-admin/themes.php?page=mobile-options

    That will restore the Dynamic News theme on mobile screens.

    Best,
    Thomas

    #132497

    Hi Thomas,
    That doesn’t seem to work (my site is hosted on wordpress.com, I wonder if that is making the difference)?

    Cat

    #132498

    (I get a 403: Forbidden when I try to access that link)

    #132584

    themezee
    Theme Author

    Hi again,

    Okay, I don’t know why that link does not work. I have notified the WordPress.com staff to take a look at this issue. They will answer here soon.

    Not sure how else the mobile theme can be deactivated.

    Best,
    Thomas

The topic ‘Mobile’ is closed to new replies.