Load more

  • Author
    Posts
  • #149396

    tmsteam38
    Member

    My load more button was not working and now it has completely disappeared.
    According to WordPress support, this has been an ongoing issue with the WP theme.
    This was their response to my help request.

    After a bit more digging it seems that the issue is related to the Oxford Theme (both child and parent one). We did have reports about Infinite Scroll settings not working as expected with this theme and it is due to the fact that Oxford theme includes Infinite Scroll functionality in its code (which it shouldn’t) and hence it’s conflicting with the WordPress.com built-in Infinite Scroll functionality.

    I conjure you to stop asking questions that suggest that the users (all the people struggling to fix this problem) are making mistakes on their end and to instead, fix this conflicting code.
    I submitted a request to your team months ago to no avail.

    The blog I need help with is themilsource.com.

    #149430

    geralttee
    Member

    Same here, and I also have the impression that this shouldn’t be so difficult after all… Dear Oxford Theme Team – please fix this as this makes your theme basically useless, and I’d hate to switch from it to some other, less buggy one.

    My blog (redacted) is the one suffering from the malfunctioning “Load more” button, see my separate three too.

    cheers
    szymek

    #149474

    Hey again, Szymek!

    After some investigation, here’s what we’ve found:

    1. In your category pages, Load More seems to be working correctly. This somehow excludes a serious bug in Oxford.
    2. On your homepage, we have a hunch that a sneaky combination of the text length of your post excerpts and your Reading settings is tricking Oxford into thinking there’s more to load, when there isn’t.

    Would you try this workaround, and see if that makes any difference?

    1. Head over to Manage → Settings → Writing → Content Types
    2. Increase or decrease your Blog Posts → Display per page option by 1.

    That should at least help us confirm our suspicions.

    krystallai38,

    We can’t replicate your issue instead. The Read More link is visible and successfully loads previous posts — did you actually fix it? Or we’re seeing different behaviors?

    Let us know your discoveries!

    #149532

    geralttee
    Member

    Hello, neither decreasing or increasing this number has any effect on the “Load more” button – it still does not work, once clicked it just disappears.

    Szymek

    #149612

    Hey Szymek,

    Sorry that didn’t help. We’re having a hard time replicating this on any of our test websites so it makes it super tricky to investigate. Would you mind answering a few questions to help us move forward with this?

    1. What WordPress.com plan is your website on?
    2. In case you’re on Business plan, do you have any plugins at all active?
    3. Could you please access your website dashboard on this link? Then head over to Settings → Reading and change Your homepage displays control to Your latest posts. Does that help?

    Let us know! And thank you for your patience! 🙂

    #149619

    geralttee
    Member

    Hi, thanks for following up.

    So going to your questions:

    1/2 – it’s Premium so I don’t have any additional plugins installed
    3 – when I change this it actually is working (so the Load more loads the posts) – the problem is this home page (latest posts) does not display the large post picture on top for the latest one, which kind of is a signature feature of the Oxford theme ;)

    cheers,
    szymek

    #149795

    scottrrollo
    Theme Author

    Thanks everyone for sharing more info! We’re looking into this and we’ll circle-back with our findings very soon.

The topic ‘Load more’ is closed to new replies.