Link pictures in gallery

  • Author
    Posts
  • #144235

    I want to make a gallery with different pictures. There, each image should be linked to a unique url / site.
    How do I make links?
    With separate images, it is possible directly in the block.
    Sincerely
    Rune

    The blog I need help with is boborg.se.

    #144236

    lelandf
    Theme Author

    Hi Rune!

    Thanks for using the Spatial theme.

    Since this is something that applies to any WordPress.com site (not just those using Spatial), you should contact WordPress.com support about this. This is the Spatial theme support forum.

    Here are instructions on how to access live chat support, for example: https://en.support.wordpress.com/live-chat/#how-to-access-live-chat-support

    Best of luck!

    Best regards,
    Leland

    #144239

    I’ve seen this now
    ” *Links can only be added to individual images. Images in galleries cannot be linked.”

    But I have tried using the text field to link with, it goes. But then I have to remove the gray background and probably also change the color of the text so that it becomes readable.
    Possible?
    Sincerely
    ​Rune​

    #144240

    lelandf
    Theme Author

    the gray background

    Can you provide a link to an example of this happening? I’ll take a look and see if it can be resolved with Custom CSS.

    #144241

    It took a while. My computer shut down. Hard reset. Jet lag :-)

    https://wordpress.com/block-editor/page/boborg.se/1813

    Password AD012019

    #144242

    lelandf
    Theme Author

    Hi there,

    Ah, I see what you mean. So that gray box seems to be there for a reason: to make sure you can read the text. However, since there seems to be a white space at the bottom of all your images, we can just set the text to be black (on white) to be readable.

    Try this Custom CSS code and let me know how it works out for you:

    .wp-block-gallery figcaption {
      background: none !important;
      color: #000 !important;
    }

    Regards,
    Leland

    #144243

    It’s 4.10 in the morning and the sun is in it’s way up. And I need a few hours of sleep. So I will se you later.
    //rune

    #144244

    lelandf
    Theme Author

    Okay, sleep well! If you have any questions upon awakening just let me know and I’ll see what I can do.

    -Leland

    #144253

    It works. But give me another problem. I have pictures on other pages with white text against black bottom. I’ve given them a black edge. May be rebuilt.
    I still don’t like the gray that goes up in the picture.
    But first I try the grey #D7D4D4

    https://boborg.se/2019/05/24/kerro-holmberg-error-malningar/

    A strange error. The linked text (BESOK / Visit) works in preview. But published it shows a slide show. The printed link works. Both show at the bottom left that they both go to the same place.

    A side issue; what can i do in the block’s advanced part: Additional CSS class

    #144255

    lelandf
    Theme Author

    Hi there,

    It sounds like you’re asking questions about a block. Since these are blocks you can use on any WordPress.com site, I’d highly recommend you contact WordPress.com support about this as they will be best equipped to help you.

    Here is the link with instructions to get in touch with live chat support: https://en.support.wordpress.com/live-chat/#how-to-access-live-chat-support

    You can also contact them by filling out this form: https://wordpress.com/help/contact

    If there’s an issue related to Spatial that I can help with, I am happy to. I just want to make sure you are getting support from the people best equipped to deal with the issues you are experiencing.

    Best regards,
    Leland

    #144258

    This is my biggest question

    The linked text (BESOK / Visit) works in preview. But published it shows a slide show. The url link works. Both show at the bottom left in the browser that they both should go to the site address.
    But only the entire address does. The linked text does not.

    https://boborg.se/vara-sponsorer/

    Password: AD012019

    You can’t answer me at all?

    Best regards
    Rune

    #144259

    lelandf
    Theme Author

    Hi Rune,

    You are asking a question in the Spatial theme support forum. I am just the theme author, not a WordPress.com staff member. I apologize for any confusion.

    I think you are asking a question about general usage of WordPress.com (questions that could apply to any theme). I just want to make sure you’re getting the best help available, and I don’t believe that can be from me on this particular issue. I don’t know the answer to your question, and why something works in preview and doesn’t published.

    I have tagged WordPress.com staff to respond to this thread. Alternatively, for a faster response, you can use the links I provided above to contact WordPress.com staff yourself, especially the “live chat” option. Have you tried that yet?

    They are the experts on using WordPress.com so I’m sure they will be much better help than I am on this issue.

    Best of luck! :)

    Best regards,
    Leland

    #144260

    I understand and I am grateful for the help I received. And I hope you understand that I do not know what is theme specific and not.
    I thought which options you get in a block to some parts are theme specific. But it is apparently the same regardless of the theme.

    Best regards
    Rune

    #144265

    lelandf
    Theme Author

    And I hope you understand that I do not know what is theme specific and not.

    I understand. :) If you’re unsure, always feel free to ask and I will help the best I can.

    Thanks again for using the Spatial theme.

    Best regards,
    Leland

    #144554

    New worries!
    Captions that have been centered are now left-handed.
    Typical pictures not those in gallery.
    Thought it might be the css code I got from you earlier. Took it away. Didn’t help.
    Everything looks right in the block editor, but in preview and when publishing, the captions become left-handed.

    #144563

    lelandf
    Theme Author

    Hi there,

    No worries. Can you link to an example page where this is happening?

    I see on this page, the captions are centered: https://boborg.se/2019/05/24/kerro-holmberg-error-malningar/

    Are you noticing it somewhere else? Or did you resolve this issue?

    Best regards,
    Leland

    #144789

    Hi Rune,

    As Leland says, for the type of help you need, we’re glad to do it through live chat. Contact us here: https://en.support.wordpress.com/live-chat/#how-to-access-live-chat-support

    We’ll be able to get you sorted quicker.

The topic ‘Link pictures in gallery’ is closed to new replies.