Jump To's Don't Work Properly

  • Author
    Posts
  • #121963

    socialamyw
    Member

    I have a couple pages that use “jump to’s” to move to different sections of the page. But, the text area doesn’t seem to be aware of the top navigation bar.

    This results in jumps that land in awkward places (the title is hidden under the black bar, or the top of the page is).

    Can you help me with this? Here’s an example of page where this is happening.

    https://amywright.me/resources/content-marketing-tools/

    The blog I need help with is amywright.me.

    #122182

    themetrust
    Theme Author

    Try adding this to your custom CSS:

    :target:before {
    content:"";
    display:block;
    height:100px; /* fixed header height*/
    margin:-100px 0 0; /* negative fixed header height */
    }
    #122183

    socialamyw
    Member

    Thank you! It worked on the content marketing tools page after I adjusted the hight to 150px instead of 100px. I’m not sure what the margin affects, but I left that alone.

    It did not completely fix the challenge on the other page where I use jumps tho.

    https://amywright.me/content-marketing-services/content-strategy-services/

    On this one, it works for jumping lower in the page, but the “return to top” link still doesn’t work right (the page title doesn’t show).

    Any ideas?

    #122221

    socialamyw
    Member

    Hi – I’m circling back on this. Do you have any suggestions for the other page I mentioned?

    #122225

    themetrust
    Theme Author

    For your return to top link, it is working correctly. You have an id of “top”, on the opening paragraph. That is what you are targeting in your jump to top link. If you want it to jump further up, you will need to use an id of an element that is closer to the top of the page.

    Try using “#page-head” instead.

    #122226

    socialamyw
    Member

    Ok – I see. That worked. Thank you very much.

The topic ‘Jump To's Don't Work Properly’ is closed to new replies.