Image sizing

  • Author
    Posts
  • #48979

    nlockier
    Member
    Original poster

    Hello, the demo photograph of the Luscious Theme shows the image much larger than I can get mine within my posts (Sample Post With Featured Image #1). My images always seem to be the same size when I upload, despite changing the picture size prior to uploading to the Image Library. How do I get all of my images to be the same size in my posts? Thanks. Blog is neilshealthymeals.com

    The blog I need help with is: neilshealthymeals.com

    #49195

    sillyandrea
    Theme Author

    Hi! Right now I see the images inserted in the posts are 300×200.

    You can insert different sizes (no matter what theme) when you are uploading and editing the image.

    #49197

    nlockier
    Member
    Original poster

    Hi, thanks for your help. When I click “Edit Image”, after uploading a new image into my Image Library, I am presented with an instruction that tells me the Image Scale original dimensions are 5184 x 3456 and that I cannot scale up, only down. So how can I change the size here please? It doesn’t seem to allow me to. Is the size of the image changed somewhere else. It’s probably just me that cant see where to do this! Thank you again! ;-)

    #49207

    sillyandrea
    Theme Author

    You can’t scale up – that will make the image blurry.

    The theme will generate image sizes you need.

    Your image is way larger than the image sizes I gave above.

    #49210

    nlockier
    Member
    Original poster

    Ok thanks. So would you be able to give me a step by step guide as to how I can make my images of my recipes on each post the same size as in the example http://theme.wordpress.com/themes/luscious please . Thanks

    #49212

    sillyandrea
    Theme Author
    #49242

    nlockier
    Member
    Original poster

    Ok thanks, but there seems to be no way of changing the default size. When I click “add media” in a post, no matter what size I have resized the picture to, it comes out as you say 300×200. Seems to be something to do with the code:-

    BakedCodTomatoBasicSauceCaperMash1
    Baked Cod with Caper Mash

    And even changing the values of “width” or “height” in that code does not work, or change anything!

    Disappointing seeing as I purchased this theme based on having my recipe picture across the whole of the width, like in the luscious example. :-(

    #49245

    sillyandrea
    Theme Author

    When you are looking at uploaded images, WordPress and the theme create multiple sizes for you.

    Pick one of the alternate sizes and insert that int to he post if you wish.

    If you mean the larger images *above* the post titles, you have to turn on the featured image setting.

    The image sizes are created after you activate the theme and upload a new images.

    If you had posts and images previously, it will not go back and resize those images.

    #49256

    nlockier
    Member
    Original poster

    Hello me again (sorry!). When I look at the uploaded images, there are no alternative sizes anywhere for me to choose from.

    I tried turning on the Featured Image setting yesterday, and again I tried today and in my normal desktop PC internet viewing it does not work. However, it did appear to work when being viewed from my mobile phone, albeit I had 2 images showing of the same photo at the top of the post.

    I only purchased the Luscious theme, not a Premium upgrade. Could that be where I have gone wrong and misunderstood? Maybe I need a Premium upgrade for all the features that we are discussing and you are recommending but I cannot find or get to work?

    Thanks again for all your help and assistance.

    #49257

    sillyandrea
    Theme Author

    No, you do not need a premium upgrade.

    Turn on the featured image setting.

    Write a new post.

    Upload a new image.

    Check the image on your post.

    #49264

    nlockier
    Member
    Original poster

    Ok thanks for this. I will have a new post at the end of this week so will follow exactly your instructions here and feedback on completion.

    #49272

    nlockier
    Member
    Original poster

    Hi There, I’ve just uploaded a new post “Low Fat Red Pesto Dip”. It’s really strange that when I preview my blog, the “Featured Image” is not there. However, the “Featured Image” is there showing when I click on my “Reader”. If you go to “www.neilshealthymeals” can you see the “Featured Image” on your own PC? Is it just that I would need to view my blog from another PC in order to see my blog with the Featured Image? Thanks.

    #49273

    sillyandrea
    Theme Author

    Did you upload the image while writing the post?
    Have you chosen that image as the featured image?
    Under Appearance -> Theme Settings, do you have the checkbox to show featured images on archive pages?

    #49274

    nlockier
    Member
    Original poster

    Hello, yes to I uploaded the image while writing the post, yes I have chosen that image as the featured image and it shows selected at the bottom right hand part of the “edit post” page as selected. However, under Appearance->Theme Setting I DO NOT have the checkbox selected to show featured images on archive pages, it is there but with no “tick” in it. Should I select it? Thanks

    #49275

    sillyandrea
    Theme Author

    Yes, that is the option that shows the larger image above the post title.

    #49277

    nlockier
    Member
    Original poster

    Fantastic! Thank you so much! It works now for all of my Postings. I see I just need to go back myself and remove the smaller thumbnail picture under each Featured Image so the picture is not duplicated, making each post messy looking.

    I really appreciate your support in helping me to fix this frustrating issue.

    Thank you.

The topic ‘Image sizing’ is closed to new replies.