I need to change "read article" to local language

  • Author
    Posts
  • #99894

    nanok
    Member
    Original poster

    I’m using the Watson theme (nanok.com) on WordPress.com and I need to change “read article” that appears after each excerpt on the first page to the Swedish translation, how? I can help with Swedish translation if you like?

    The blog I need help with is: nanok.com

    #100008

    Hi @nanok

    There is a way for you to help with the Swedish translation. Here is the guide to getting started:

    https://en.support.wordpress.com/translation-faq/

    And here is the repository for the Swedish translation for Watson:

    https://translate.wordpress.com/projects/wpcom/themes/watson/sv/default/

    Thanks!

    #100264

    nanok
    Member
    Original poster

    I’ve translated the lot and I’m waiting for “approval”. I happen to be “professional” writer myself (English and Swedish) and I’ve done many UI translations before. Maybe you could trust this translation to be “good enough”?

    Best regards,
    Nanok Bie

    #100265

    nanok
    Member
    Original poster

    To be clear; some elements of the UI HAVE changed to Swedish (for instance Read Article which is now in Swedish, BUT: “Posts from the ‘Artiklar’ category” – this part shows up after each search or from a category link, and I’d of course like that first prominent part to also be in the local language.

    Best
    Nanok

    #100268

    scottrrollo
    Theme Author

    Thanks so much, Nanok! 👍

    I believe GlotPress validators will review your submission.

    Was there no option to translate the phrase ‘Posts from the ‘Artiklar’ category’?

    #100284

    nanok
    Member
    Original poster

    No, there is no option for that part. How can I get rid of that or change it into my local language? Please advice :)

    Best,
    Nanok

    #100288

    scottrrollo
    Theme Author

    Hey again, Nanok!

    It sure sounds like that part of the theme cannot be translated. I’ll pass it along to the team, but I’m not sure exactly when we’ll get around to patching this up.

    Sorry that’s not the answer you’re hoping for.

    #100290

    nanok
    Member
    Original poster

    Aha, well that’s really disappointing as it shows up very prominently in large bold letters after each search, in the middle of another language. Is it possible to remove it totally with som CSS-trickery or similar?

    Best,
    Nanok

    #100291

    nanok
    Member
    Original poster

    To be clear, it does not show up after a “search” per se, but on all listings of posts in the same category, which (I guess) is the easiest way to get posts listings in the same category? Or I might device a search from each menu option on a special word, and I place that word in each such post – but it kind of defeats the purpose and idea of categories and tags, you know?

    Best,
    Nanok

    #100304

    scottrrollo
    Theme Author

    Got it, Nanok. That makes sense.

    To hide that English phrase from your category archive, try this:

    body.archive .subheading {
        display: none;
    }

    I hope this helps! And thanks so much for working around this with us. 😀

    #100305

    nanok
    Member
    Original poster

    Yay! That worked, thank you very much :D

    #100308

    scottrrollo
    Theme Author

    Woohoo! Happy to help, Nanok! 😀

    If you have any more questions, just ask away.

The topic ‘I need to change "read article" to local language’ is closed to new replies.