How do I set an image to show up with the post in the Reader?

  • Author
    Posts
  • #52394

    samara166
    Member

    When I set the featured image, I get both a thumbnail picture next to the post title, AND the large image at the top of the post.

    And the issue I’m trying to fix – which is that the post randomly displayed the music video at the end of the post, in the Reader – wasn’t even changed.

    I have a very specific post image I want to show up when my blog comes through the Reader. How do I do that?

    The blog I need help with is samaraspeaks.wordpress.com.

    #52502

    Hi!

    I’m not sure that I understand. Could you please elaborate further on the issue?

    Perhaps, you could send me a screenshot? (You can use http://awesomescreenshot.com for that) That would help a lot, thanks :)

    #52508

    samara166
    Member

    Hi!
    I took a screen shot with my computer, but i don’t seem to be able to post it in here.

    At the top of my post I have an image that goes with that post. It’s of parents and a child.

    However, I have a music video at the end of the post.

    In the Reader, my blog post is coming up with that video, instead of the main post image that accompanies my post.

    When I use “set featured image” I get a double of my post image. I get the same image in my post, twice. A small one on top, near the title.
    And the original large one, that I actually want, right below the title.

    But my blog, in the reader, still has the music video instead of the image that I would like to accompany my post.

    I know there’s a way to set up which image you want your post to display when it appears in the WP reader. I just don’t know what that is.

    Thanks.

    #52599

    Hi!

    Thanks for clarifying!

    I did some digging and found the following:

    I have discovered that on WordPress.com, the intended behavior for a post with an embedded video is to prioritize the video for the featured image, over a regular image. The only post formats where this doesn’t happen are Gallery and Image formats.

    I think it may work a little differently with different video types, but this is definitely how it works with YouTube.

    So if you have a YouTube video embedded in your post, it’s going to be what shows up in the Reader, and that’s by design.


    Link to the thread: http://en.forums.wordpress.com/topic/why-does-reader-show-video-rather-than-first-image?replies=15

    Hope that helps.

    #52689

    samara166
    Member

    Thank you for your explanation.

    It’s a little frustrating though, especially when I paid for the upgrade.

    The video is just not what I want people to see first.

    Do you have any idea if they’re fixing it?

    #52692

    I’m afraid, they don’t plan on changing that.

    I can only speculate, so I’d recommend bringing it up in the General Forums: http://en.support.wordpress.com/

The topic ‘How do I set an image to show up with the post in the Reader?’ is closed to new replies.