How do I make my attached image 'not clickable'?

  • Author
    Posts
  • #127182

    Hi,

    I am creating my photo gallery under portfolio. Currently, when I click one of the images, it goes into individual photo link and allows users to download the image at full-resolution.

    Is there any way to prevent that? When I was attaching these images, I selected “no link” option, but it didn’t help.

    Thanks,
    Ramon

    The blog I need help with is midgray.com.

    #127397

    themetrust
    Theme Author

    Hi Ramon,

    The gallery that I’m seeing opens the image in a slideshow. Do you not want it to open the slideshow?

    #127406

    Correct. I want to display the photos in Tiled Gallery or 3×3 Thumbnail, but dont want it to jump to the slide (carousel?) mode when each photo is clicked.

    Apparently, when I attach photos individually, clicking each photo won’t jump to the slide (when I set LINK=NONE in the attachment option)
    The issue seems to be only applied to when I attach photos as Gallery.

    #127422

    themetrust
    Theme Author

    There is a Link To select field in the gallery settings, but it seems even if it is set to None, the images still link to the carousel.

    I’m tagging this topic for a WordPress.com support staff member to take a look.

    Someone will reply here soon.

    #127423

    kathrynwp
    Staff

    I had a look at one of your portfolio gallery pages here: https://midgray.com/portfolio/camden-town/

    There isn’t a way to use a tiled gallery without the carousel; they work together. You would need to choose the thumbnail gallery option instead.

    If you’re concerned about people downloading high-res images, a couple of options I can think of include:

    – watermarking your images before uploading
    – making the images smaller before uploading

    Also just a heads-up that since your site has a Premium plan, you’re entitled to live-chat and email support, accessible here:

    https://wordpress.com/help/contact

    You’re welcome to still post in these forums, but those other support avenues may be faster, and you’ll always get a staff reply.

    #127441

    I witched to the Thumbnail gallery as you suggested, but the photos still jump to carousel when clicked (e.g. https://midgray.com/portfolio/brick-lane/)

    Is this working as intended?

    #127461

    kathrynwp
    Staff

    Hi there – you’ll also need to turn off the carousel in WP Admin’s Media Settings area.

    https://18percentgray658503977.wordpress.com/wp-admin/options-media.php

    Uncheck the box next to “Display images in full-size carousel slideshow.”

The topic ‘How do I make my attached image 'not clickable'?’ is closed to new replies.