Home page slow loading and more…

  • Author
    Posts
  • #155329

    Hello,

    I have a few questions:

    When clicking on my homepage, there is a large (gray background) area between the top scrolling image(s) and the 3 middle content blocks upon loading. It lasts about 5 to 10 seconds and effects the user experience. Is this due to a plug in or something else? Is there a way to prevent this from happening??

    Also, I recently added the RankMath plugin to the site and when configuring the sitemap settings I get the following message:
    “Since you are using NGINX, add this code to your NGINX configuration file if your Sitemap pages are not loading or you can ask your hosting support to add it. Click here to see the code.”
    How do I get help in getting this done? Is this preventing Google from indexing my site?

    Thanks for your help on the above.
    EA

    The blog I need help with is claimsaidconsultants.com.

    #155429

    itsdavidmorgan
    Theme Author

    Hello,

    No problem.

    Regarding the gray box, this space appears as a placeholder while the slideshow is loading. The slideshow requires a little more time to load than other smaller elements on the page, so the space is visible until it’s fully loaded.

    I pushed an update to the theme that will make the slideshow placeholder background white instead of gray, which should help the appearance.

    Regarding the 5 to 10 second load time, that seems considerable, and is probably a result of your personal internet connection speed. When I view your site, the placeholder only appears for about 1 second before the slideshow loads.

    Regarding the RankMath question, that is a question for their plugin support team. This forum is meant only for theme related support questions.

    Let us know if there is anything else. Thanks!

    #155436

    Hi David,

    Thanks for your reply!

    Earlier today I figured out why the bottom images were taking so long to load. Apparently I had the”lazy load images” option checked (in settings), so as soon as I unchecked it — my problem was solved! Big difference — now the page loads fine.

    Also, it seems that Google is successfully indexing the site now so that NGINX message that appears may not even be an issue.

    Thanks again for your help!
    EA

    #155468

    mippr
    Member

    Thank you EA for posting the solution! I have been having the same issue and it was driving me crazy. I unchecked the “lazy load images” option and it works so much better. Whew!

    Shelly

    #155578

    emilysuesrq
    Theme Author

    Great to hear! Thanks for sharing your solution regarding Lazy Load. Let us know if you need anything else.

    Kind Regards,

    Emily

The topic ‘Home page slow loading and more…’ is closed to new replies.