"Hide author" and "Disable two-column formatting on this post"

  • Author
    Posts
  • #56465

    satubell01
    Member
    Original poster

    Regardless of whether I’ve ticked those boxes or not, my first name shows above posts and one-column formatting is on – despite the fact that the default is set to two columns.
    What could be causing this issue?
    I use Safari.

    The blog I need help with is: nojatuolihaahuilija.wordpress.com

    #56576

    scottrrollo
    Theme Author

    Hello!

    I’m not seeing your name above any blog posts. Where specifically are you seeing this? Is this still a problem?

    one-column formatting is on – despite the fact that the default is set to two columns.

    Can you please check if you have any content in your Excerpt input? If yes, you may want to try removing this.

    #56580

    satubell01
    Member
    Original poster

    What I see is ‘Satu’, centered and between two thin lines, right under my site title&tagline, and I also see it when I click on individual posts to open.
    I remember having it there a long time ago when I first starting my blog, but I removed it.

    How do I find out whether I have any content in my Excerpt input? I don’t understand what that means, sorry!

    #56593

    Hi there!

    The “Satu” that you’re seeing beneath the title and tagline is a menu item in a custom menu. You should be able to edit the menu to remove that item.

    Here’s some info about excerpts.

    #56601

    satubell01
    Member
    Original poster

    !!! 😄 Had I clicked on the “Satu” I would’ve immediately realized that the page I thought I’d deleted was still there..! One click too few…

    I did know about excerpts, a feature which I haven’t used in my blog. I was just confused by “content in excerpt input”, I thought that was something specific/different, did a search, which didn’t yield an answer, hence the confusion…
    It obviously doesn’t take much to confuse me…😃 Sorry! (because this won’t be my last question here…)

    #56628

    scottrrollo
    Theme Author

    No problem! We’re glad to help :)

    If you have any more questions, please open each in a new topic.

    #56654

    satubell01
    Member
    Original poster

    I went through this excerpt stuff again: I do not have any content in excerpts, I’ve never used that function.
    Yet I simply cannot make the two-column formatting to work! I’ve tried to make it appear both on a new blog post I’m currently working on and on older posts, to no avail.

    #56676

    scottrrollo
    Theme Author

    Hi again!

    We’re not sure what could be causing this problem, sorry. Thanks for your patience, though, while we work through this.

    Can you please try copying all your post content into a new post? It’s possible your current post is not formatted correctly or an option has been changed.

    #56696

    satubell01
    Member
    Original poster

    I copied the content into a new post, but it made no difference. I also re-checked all the settings again, but as far as I can tell, everything is as it should be.

    Originally I thought the custom upgrade might have caused the issue because I never had this problem before getting the upgrade, but all I used it for was to change the fonts and colors (which I’ve since returned to the default settings.)

    Since I bought my new computer I’ve been using Safari. Before, I used mainly Firefox or IE, but also Safari sometimes, and I never noticed any kind of difference.

    This is not the end of the world for me in the sense that so far I’ve hardly ever used the two-column default option, mainly because of the way photos are displayed. However, a while back I came up with a new idea for my blog and I would need to use two-column formatting for that. And in any case I’d like to get to the bottom of this issue. Two columns are what Duet is all about, after all.

    #56714

    scottrrollo
    Theme Author

    Hello again! Thanks for trying that.

    Can you please share a link to a specific post that you’re working on that doesn’t display two-columns correctly? This will help us to troubleshoot this problem.

    #56819

    satubell01
    Member
    Original poster
    #56824

    scottrrollo
    Theme Author

    Hi there!

    Both of these links are to unpublished posts. Can you please publish these so we can take a look?

    #56826

    satubell01
    Member
    Original poster

    Oh, when you asked me to share a link to a post I’m “working on” I thought you meant an unpublished one! Sorry!

    I just published the first one:

    http://nojatuolihaahuilija.wordpress.com/2014/08/20/sano-se-pilvin-pimein-pilvitse/

    Btw, I also looked at my blog on a standard desktop screen using Firefox, and it looked SO MUCH better!! Text was perfectly aligned with full-size photos AND galleries so that the width was identical (which is not the case with my laptop and Safari) and the right sidebar was within the frame, beautifully separated from the text section by the lovely thin, dotted line I so like about Duet. In short, everything looked the way it used to before, with Safari as well.

    Whereas now, with Safari, what I see is that photos and text do no align, or only occasionally and it’s not possible to center any galleries (like it used to be). The vertical dotted line is not there at all. All in all, a haphazard look without the right sidebar there.

    EXCEPT that this post now had two columns, even though it’s never had them before:

    http://nojatuolihaahuilija.wordpress.com/2014/07/21/pienin-isoin-ja-sitten-se-erityinen-viehatysvoima/

    #56827

    satubell01
    Member
    Original poster

    Just to let you know:
    I had no choice but to disable two-column formatting on the post you were going to look at because I looked at it with a variety of devices and browsers and saw that especially on a tablet it was all messed up. It did show two columns, but with huge gaps of empty space here and there, rendering the post very difficult to follow. Not to mention the fact that it looked ridiculous.

    I didn’t really have any problems with Duet until the last couple of months or so. I don’t mind the photos not aligning the way I’d prefer, I know I’d have to use CSS to make things more accurate, but what I do mind enormously is that some of Duet’s basic features don’t seem to work properly anymore and that there’s such a huge difference across devices/browsers.

    #56829

    tollmanz
    Member

    Hi Satu!

    I am sorry that you continue to experience issues with the theme. I am curious, have you observed these problems with our demo site.

    #56830

    satubell01
    Member
    Original poster

    Hi there (again..) !

    The demo site is great! No problems there. However, the demo site does not have sidebar widgets nor any image galleries, two things that cause me problems (as on some browsers the right sidebar widgets are moved to the bottom footer, vertically, rendering the bio photo much bigger (and taking up a lot of space anyway), and I cannot center image galleries, they always stay on the left and are easily “torn apart”, with photos suddenly displaying, not side by side or in a mosaic tile, but one on top of the other, always on the left side.)

    I use a MacBook and I normally keep the Dock at the bottom. However, yesterday I suddenly decided to move it to the left-hand side of the screen and pulled the browser window downward by about an inch. As a result, the right sidebar reappeared as the post section became narrower. Photo placement suffered here and there, but at the same time a recent two-column blog post improved considerably: When the Dock is at the bottom it’s completely off balance, with 90% of the text on the left and only a few lines on the right.

    So when the Dock is at the bottom I have the right sidebar and two-column formatting goes astray and when the Dock is on the left-hand side my blog looks just like your demo site, but my widgets are at the bottom and my bio photo is far bigger than it should be. A very small difference in browser size makes a big difference in terms of how my site looks like.

    What I want to do is to try to minimize differences across browsers/devices. I obviously have to make a change to my widget placement as the right sidebar simply doesn’t work. I also have to rethink how I display photos as the distortions are at times considerable. I hate the idea of my dear blog looking to some readers like it’s a stinky mess!
    I would also really hate to give up on Duet despite the headaches it’s given me lately, as it is the most beautiful and elegant theme I’ve ever seen.

    Would you be able to point me towards any additional info/tutorials etc. concerning a responsive theme like Duet, and how to keep changes/distortions to a minimum? I’m sure I’m not the only person who struggles with these issues.
    (And what is up with the image galleries refusing to center??)

    I will open any new or follow-up questions in a new topic, this thread is already long enough.. : )

    Thank you very much for your assistance!

    Satu

    #56834

    scottrrollo
    Theme Author

    Hello Satu!

    It sounds like you may be trying to disable Duet’s responsive grid, is this correct? Unfortunately, this isn’t possible because the responsive grid is built directly into the theme and cannot be removed without rewriting the CSS (Style) code.

    What specific problems are you trying to solve by adjusting the grid?

    #56839

    satubell01
    Member
    Original poster

    I have obviously expressed myself very poorly (which is depressing as I’m a linguist and a writer..!).
    I don’t want to adjust or disable the responsive grid. I realize the theme has to adapt to fit different browsers and devices.

    What I do have a problem with is Duet adapting so much that it throws my blog into disarray. What I’m looking for are ways to minimize those changes to keep my blog as neat as possible.

    I take it from your replies that CSS is the only way to solve the problems I’m experiencing.

    The thing is, though, that until about 2-3 months ago I didn’t have any of these problems:
    – picture galleries could be centered (whereas now they always align to the left)

    – formatting worked fine (whereas now there’s one column even though I enabled two-column formatting, or sometimes vice versa)

    – the layout was more stable across devices/browsers in terms of image alignment and size (whereas now, image galleries in particular are often “torn apart”, the photos showing one on top of the other on the left, leaving a large area beside them completely blank)

    Like I said, I didn’t have these problems before.

    #56841

    scottrrollo
    Theme Author

    Hi again, Satu! Thanks for explaining this.

    We haven’t made any major changes to Duet during this time—it’s quite possible these issues are caused by changes made to the WordPress.com platform itself. Either way, we’re certainly happy to help you get these issues sorted out.

    Can you please provide us one link to a gallery that is incorrectly aligned?

    Can you please provide us one link to a post that is displaying the incorrect column layout?

    From here, we’ll take a closer look at the code and see if these problems are caused by bugs in the theme.

    Thanks!

    #56844

    satubell01
    Member
    Original poster

    Here’s a link to a post where the photos aren’t aligned properly, BUT ONLY when my browser window is about an inch shorter (due to the Mack dock being at the bottom of the screen). As soon as I move the dock to the side (making the browser window bigger) my blog posts change their appearance and this one, too, then looks much better:

    http://nojatuolihaahuilija.wordpress.com/2014/08/20/sano-se-pilvin-pimein-pilvitse/

    Here’s a link to a post which is supposed to have two columns, but keeps changing between one and two for the reasons mentioned above – and depending on the browser/device:

    http://nojatuolihaahuilija.wordpress.com/2014/08/07/helteet-kuulutukset-ja-pullo/

    So some of my readers, depending on the size of their browser window etc. see my blog posts very nicely aligned. Others, though, might see something very different – which is why my plan is to go through all my posts and simplify things, for example get rid of a lot of image galleries.

    I really want to minimize these disruptions as much as possible.

The topic ‘"Hide author" and "Disable two-column formatting on this post"’ is closed to new replies.