Header bar question & Plug-in question

  • Author
    Posts
  • #159029

    workthewater
    Member
    Original poster

    2 questions:
    1. White logo used in top left and white font on menu. Looks great until you scroll up where the menu minimizes. The font switches to black but my logo almost disappears (since it’s still white). Is there a fix for this? I looked at other posts but didn’t really see anything that seemed to work for me.

    2. I am trying to embed a Spreadshop plug in but when I do it cuts off the header image on this page (https://workthewaterfront.com/official-merchandise). Is there a way to fix that with CSS?

    The blog I need help with is: workthewaterfront.com

    #159041

    tarasdashkevych
    Theme Author

    Hello,

    “The font switches to black but my logo almost disappears (since it’s still white). Is there a fix for this? “
    – By default, WordPress does not allow to upload multiple logos.

    On the hand, we can use a custom CSS to fix this issue. For example, we can change a background color of the header section during a scroll. I can help you with a custom CSS. Please make your site public, so I can inspect the section.

    “I am trying to embed a Spreadshop plug in but when I do it cuts off the header image on this page…”
    – Could you please make your site public, so I can inspect the page?

    Kind regards,
    Taras

    #159042

    workthewater
    Member
    Original poster

    Thank you Taras, the site should be public now.

    #159043

    tarasdashkevych
    Theme Author

    Thank you for marking your site public!

    Please add this custom CSS to change a background color of the header section during a scroll:

    
    @media (min-width: 768px) {
      .site-header.scroll-header {
        background-color: #002e6e;
        color: #ffffff;
      }
    }
    



    “I am trying to embed a Spreadshop plug in but when I do it cuts off the header image on this page”

    – Are referring to this image (https://snipboard.io/cO6NpL.jpg) ? If not, could you please share a screenshot of the issue?

    Thank you,
    Taras

    #159044

    tarasdashkevych
    Theme Author

    If you are referring to the site logo, then please add this custom CSS to your site:

    
    @media (min-width:768px) {
        .page-id-297 .site-content {
            margin-top: 50vh;
        }
    }
    
    @media (min-width:992px) {
        .page-id-297 .site-content {
            margin-top: 18vh;
        }
    }
    

    Where 297 id the ID of the page (https://wordpress.com/support/pages/#how-to-find-the-page-id).

    It looks like the plugin changes the structure of the page, and as a result, this issue appears on your site.

    Please let me know if you have any additional questions.

    Kind regards,
    Taras

    #159045

    workthewater
    Member
    Original poster

    Awesome! That fixed both issues. Thank you thank you!

    #159095

    tarasdashkevych
    Theme Author

    You are very welcome! :)

The topic ‘Header bar question & Plug-in question’ is closed to new replies.