Full Width Image in Portfolio Pages

  • Hi there,

    I’m having a tough time formatting an image inside of the portfolio pages to be displayed full-width like they appear to be able to be formatted in the customized Bailey demo. Would you be able to assist me with this?

    The blog I need help with is: (visible only to logged in users)

  • Hey there, Naomi 👋 Happy to help!

    Before we dive into any technical checks, have you had a chance to read through our help guide? There’s a section there called, ’Full-Width Images’ — be sure to read that because it explains how to do what you’re after.

    Let us know if that helps or if you’d like more guidance!

  • Hey Scott,

    Actually I did read that help guide, but I’m having a hard time finding where ‘attachment display settings’ is in this block format?

  • Ah okay! That makes sense, Naomi.

    WordPress recently made some really big changes to the way the platform works and looks, and so Bailey’s help guide is a bit out of date — sorry!

    Instead, try using the classic editor for your website. Jus click that link to take you there.

    With the classic editor, you should then see the attachment settings you’re looking for.

    I hope this helps!

  • Hey Scott,

    I’ve actually been using the classic editor all along to edit my site. Still not exactly sure where the ‘attachment settings’ are… Is it within the attachment details in the media uploader, under ‘edit image’? Cause I changed that to be 1042 pixels and the image still doesnt show up spanned fully across the left-hand side like it does in the theme preview.
    Let me know if you have more advice on how to get the image fully spanned across the space as it does in the theme preview. Thanks

  • No problem, Naomi! Happy to help.

    Would you please try following these steps and see if that helps?

    1. Head over to your Portfolio > All Projects.
    2. Click to edit your project.
    3. But your cursor in the content editor and click the ‘Add Media’ button.
    4. Select an image but don’t yet click ‘Insert into post’.
    5. On the right-hand side of the screen (you might need to scroll) you’ll find the ‘Attachment Display Settings’.
    6. In these settings, set Size the ‘Full size’.
    7. Now click ’Insert into post’.

    I hope this helps 😀 Let us know!

  • Hey Scott,

    Appreciate your followup here, the only problem is that there just isn’t anywhere that says ‘Attachment Display Settings’ in the WP Admin portfolio editing mode. There is an ‘Add Block’, ‘Add Image’, or ‘Add Gallery’ option when editing portfolio pages but nothing that specifically says ‘Add Media’, just access to the ‘Media Gallery’.

    Even still, following your steps with the closest option being ‘Add Image’ and selecting something from the media gallery, there is no ‘Attachment Display Settings’ on the right hand side, only ‘Attachment Details’ being URL, Title, Caption, Alt Text, and Description. Once you add an image, there is options for alignment and image dimensions but nothing that says anything specifically about ‘Size.’

    Hope this clarifies things on my end a bit more for you cause it sounds like we may be working with different WP admin interfaces.

    Let me know if you can still assist me with this issue or even if a simple line of code could remedy this problem.
    Thank you!

  • How strange! It sure sounds like we’re looking at different interfaces, Naomi.

    When you sign into WordPress, on the left-hand side, can you see a link labelled ‘WP Admin’? It should be at the very bottom of the menu.

    Please click ‘WP Admin’ then follow along with the 7 steps I shared in my previous reply.

    Fingers crossed that works!

  • The topic ‘Full Width Image in Portfolio Pages’ is closed to new replies.