Files not playing in Audio player but play everywhere else

  • Author
  • #88680


    I am finishing up my site with you all and I have only run into one issue I needed to write about. My Soundcheck music file is not recognizing the audio posts I am putting up or I am making some error. When they rotate in the background the audio works when I press play, as well as in the post. However when I click on play in the soundcheck widget it gives me the male voice telling me to upload audio to this post. Since I see it working elsewhere it seems like there is an error somewhere. Any suggestions? Thanks much- Geoffrey Dean

    The blog I need help with is


    Theme Author

    The custom audio players and widgets use MP3 files uploaded to a post. This can be done by clicking the “Add Media” button above the editor. You can then upload the audio files there. It’s important to actually upload the files and not select files already uploaded to the post.

    When a file is uploaded to a Post, WordPress attaches that file to the post. The theme then grabs all audio files attached to the post into a player automatically. You do not need or want to add any audio files or shortcodes to the content area.

    The widget in Soundcheck will automatically pull the audio from the specified post as well. If you’re getting the default audio notice, that is letting you know there haven’t been any audio files uploaded to that post.

    There is more information on this via the theme documentation here:



    Thanks for the response, as I said I am uploading them with the post, when I create a post I hit add media which takes me to my media library, at that point the only option is to “Insert” from my media library. I see no direct upload feature other than attaching the files already existing in the media library. I have even added new songs with new posts to see how that worked and cant figure out why. I understand what you are saying about content area but I see no other option. I have done this and like I said in the post there is audio, and it plays— when that same post is in the hero sliders and I hit play, it plays. However in the audio widget it is having trouble recognizing this audio and it is not playing. This discrepancy is what I dont understand since I see no direct upload option and otherwise have the audio working everywhere, sorry if Im missing something please clarify thanks !!


    Theme Author

    Unfortunately, can get a bit confusing with the old interface and the new interface. I’m going to assume you’re using the new interface.

    When clicking on the small image icon to Add Media, you’ll be presented with the Media Library popup window. You should see the title “Media Library” and to the right of that title are two buttons, “Add New” and “Add via URL”. If you click on the “Add New” button, you should be able to select files from your computer.

    It took me a few seconds to find this method of uploading files to a post as well, but once you know it’s there, it’s easy. I’m still used to the old admin and way of doing things, which is similar to self-hosted WordPress sites.

    I think this should help do what you’re looking to do.


    Thanks, ya I could see through old screenshots of wordpress when I was researching this that upload window that no longer exists. Glad we are on the same page with all that now- that being said, this is exactly what I have been doing and this is where the problem is. I have correctly attached the media to the posts, it plays everywhere else on the site except the widget, I have one playlist where it doesnt even recognize it and gives me the male voice, and a second where the tracks (only 2 out of the 4 on the post) show up, but upon pressing play nothing happens and it doesnt work. This leads me to believe there is something going on between wordpress and your widget now because It seems like I have done everything exactly as I should and its just not working. Appreciate your help will be happy to hear back, if you want my PW and info to go in from my end Id be happy to offer it. Best, Geoff


    Theme Author

    I just tried creating an audio post in Soundcheck using the new admin UI and I wasn’t able to get things to work either. That said, if I use the old admin UI, thing work as expected. I’ve contacted to see if they can help get this worked out. In the meantime there are a few things you can do.

    1. Update your audio posts via the old admin area. You should be able to click on a post and Update.

    2. It looks like some pages have a bunch of audio players in the content and it’s a bit confusing what you have going on. I’d recommend removing the audio players from the content area for now as they are not needed and add additional page load resources.

    I’ll follow up with you once I know more about why posts aren’t being published correctly using the new Admin area.


    Thanks, can you let me know how you accessed the old admin UI and I can try that way? I havent seen any option to revert to that just want to get this thing working asap, that player was basically the reason I bought this theme because it looks better than the other players offered.

    Thanks ya definitely would like things full functioning one way or another and appreciate it hope wordpress can give you some good answers.


    Theme Author

    When logged in, I can access the old admin area via the dark admin bar at the top of the page. There you should see “My Sites” and show a WP Admin link in the drop-down. That said, I’ve heard some users don’t have this same bar. If nothing else, just add “wp-admin” to the end of your URL like this:

    Soundcheck was really the first theme on that offered full audio and playlist functionality. This was five years ago, though, and since then WordPress has evolved and changed, especially when it comes to media management.

The topic ‘Files not playing in Audio player but play everywhere else’ is closed to new replies.