Featured Image on Ampersand

  • Author
    Posts
  • #56879

    lea3358
    Member

    Hi,

    While trying to find a solution as to why no image was appearing on linking my site homepage to FB, Linked-In etc I found an online suggestion to set the required image as a featured image. However when I do that on Ampersand I get the featured image overriding the background image I have put in the header and putting it there. As my site is live I had to remove it straight away (as it produced a ghostly half face through the semi- transparent header!), Should the featured image be positioning itself unrequested in the header on Ampersand? Many thanks.

    #57030

    thejohnparris
    Theme Author

    Hi,

    Yes, the featured image overrides the global header image. It’s meant to give that subtle image effect that ties into the content people are viewing. There’s an option that disables it under Appearance > Customize, but it also disables the global header image. If you’re interested in that, it’s called “Header Background Effect”.

    #57059

    lea3358
    Member

    Thank you. I am wondering if this is the reason that when I link to Facebook I am just getting a white box and no image. Do you think if I disable the ‘header background effect’ in Appearance > Customise and set a featured image I want to appear on Facebook that will solve the problem of no image appearing on FB.

    It would be a shame to lose the background effect but probably a better option than a blank box appearing when linked to social media.

    I have designed a website for a friend and she wants an image on FB rather than a white box and other sites I have done always show an image so am wondering if it is the theme? Many thanks.

    #57070

    thejohnparris
    Theme Author

    Yes, Facebook should be using the featured image as an image option when you post links there. If you paste this link from the demo site into Facebook, it pulls in the appropriate image.

    Can you try sharing a link on Facebook where you’ve assigned a featured image so see if it pulls in the right image? Also, if you continue to have problems, could you share a link to your site so we can take a look?

    #57082

    lea3358
    Member

    Hi, I added a featured image to the posts page (as on the posts page it doesn’t override the header) but it still just shows a white box when sharing to facebook. The site I need help with is:
    helenfostercoaching.co.uk

    Many thanks

    #57089

    lea3358
    Member

    Hi again……just further to my last message. The share on Facebook shows an images when I share any page other than home. But it’s the home page I want to share of course!

    I haven’t added a featured images but if I share the About page it takes the image of the person which is the most obvious one and is the one I want. I just can’t work out why it won’t do it with the home page and have spent hours trying to work it out.

    Any further advice on why an image doesn’t show up from the homepage would be much appreciated as this has worked with other themes. Many thanks

    #57096

    momntco
    Member

    Hello,

    First of all, your customizations to the original theme look great. Nice work!

    As for your issue, are you able to add a featured image to the page you’re using as the home page?

    #57097

    lea3358
    Member

    Hi,
    Thanks for the kind words! Am learning slowly and am hugely grateful for this support forum.

    Yes, I am able to add a featured image to the home page but it overrides the background image I have set for the header and instead places a ultra large image of the bottom half of the face of the person (looked quite terrifying!). So I had to remove the featured image. I then removed the background effect and added a featured image on the home page, but again, that didn’t work and I get the link on Facebook but just a white box where an image should be.

    It works OK with the About page so I was wondering if there was some problem with a setting on the Home page that stops images being shown when sharing on Facebook?

    Many thanks.

    #57099

    momntco
    Member

    Thanks for clarifying some things…hm…what do you see in Facebook if you test the ampersand demo site’s home page? http://ampersanddemo.wordpress.com/

    Like John said above, the demo site’s post pages will work as desired, but I’m curious about the demo site’s home page. Let us know if an image is grabbed by Facebook, and if so, which one.

    Thanks!
    George

    #57101

    lea3358
    Member

    Just tried that and when I try to link the ampersand homepage to Facebook it does the same thing and just shows a blank white box where an image should be. The link is there and works, just no image.

    Many thanks!
    Louise

    #57102

    thejohnparris
    Theme Author

    Hey Louise,

    What happens when you:

    A) Enable “Header Background Effect” in Appearance > Customize
    B) Set a featured image on the home page.

    and then paste the homepage link into Facebook? Obviously you’ll want to use another featured image there instead of the “terrifying face” image. :)

    If you don’t specify a featured image, wordpress.com adds a blank one in the header info that Facebook looks at to determine what to show.

    To test this with our demo site, I temporarily added a featured image to the homepage, and pasted the link into Facebook. Here’s what I got. Here’s what the homepage looked like with that image.

    Further complicating this is that Facebook often saves copies of previously pasted links for a while so they don’t have to keep fetching it from the source. So, sometimes when you make changes, Facebook won’t see them immediately. There’s a technical tool they have for troubleshooting which forces their systems to fetch the site again. If needed, you can try it out to force them to refresh their systems.

    That tool is here. You paste the link to your site in the box and click Debug. It will show you a list of items. As you can see in this screenshot, they have your featured image set as a blank.jpg because wordpress.com automatically adds that when you don’t assign one.

    You can force them to refresh it by clicking the “Fetch new scrape information” button. Do this after you’ve assigned your new featured image. It should update that blank.jpg to your new image. Afterwards, close your browser completely, go back to Facebook, and try posting the link and see if it pulls the image in.

    This is tricky because as you noted, the photo of the person doesn’t sit well as a featured image. Maybe you can try another image that’s not the person but fits the business concept?

    #57104

    lea3358
    Member

    Thanks so much for this help. I tried that and have set a new featured image on the home page which would work as a link image (and doesn’t look too scary in the header!).

    Tried to do the debug and fetch new scrape information but it didn’t update that blank.jpg and again no image showing on FB. Perhaps it just needs me to walk away from the computer for a while and log off.

    For now though I will suggest that the ‘about’ page is shared on FB as the link as the picture of choice of Helen comes up then (pulling it from the page and not a featured image).

    Have learnt a lot here though, so many thanks!

    #57105

    lea3358
    Member

    …….just a final thing I have just noticed. I just tried adding a new featured image to the ‘about’ page and linking on FB, but it ignored that and instead chose the photograph on the about page.

    Have changed it back now, but it’s quite strange.

    #57173

    momntco
    Member

    Hey Louise,

    John’s steps above seem to work quite well. Now that some time has passed since you last tested this, if you do the steps he recommended, does anything improve?

    #57239

    lea3358
    Member

    Hi,

    I couldn’t resolve the picture not appearing on FB when sharing the homepage, even when a business themed image was set as the featured image. But sharing the ‘about’ page was possible on FB with an image and was actually fortuitous in that in means the site is getting more hits beyond the home page.

    Thanks so much for your help. Will mark as topic resolved.

    #57243

    momntco
    Member

    Hi Louise,

    Sorry we couldn’t figure out the weirdness with the homepage…it’s an odd issue, especially considering the behavior we were able to notice with the official Ampersand theme demo website.

    Thanks for your patience and flexibility with the issue. If another problem or question pops up, don’t hesitate to come back – hopefully we’ll be more helpful next time :)

    Best of luck with your site,
    George

The topic ‘Featured Image on Ampersand’ is closed to new replies.