Feature Page not working on Home page

  • Author
  • #159310

    I’ve tagged the blog posts that I would like to have shown on the home page but when I update “Featured Content” to display the “Featured” tagged posts they don’t appear. I’m clearly doing something simple wrong. Please advise? Thank you!

    The blog I need help with is: (visible only to logged in users)

    Original poster

    I was able to fix the first issue by creating the page but now it’s not showing up as the nice clean 3 pictures to select from like the display model. It’s listing the entire blog post. How do I go about cleaning it up to just show the featured image and allow users to click on that image?

    Theme Author


    I just loaded the home page and I’m only seeing two links to posts. Can you check to make sure the following steps have been done?

    – Make sure a page is chosen under Customize → Static Front Page → Front Page
    – Apply the Home Page template to that page.
    – Ensure you have a Featured Image selected for the page.


    – Navigate to Customize → Theme Options → Home Page Template.
    – Choose the pages you would like to appear on the homepage using “Home Template Featured Page One,” “…Two,” “…Three,” and “…Four.”
    – Click the blue Save button at the bottom.

    You can specify an image to be displayed in the background of each “Featured Page” post by setting a featured image for that post.

    That should get you started with the photos you mentioned from the demo. There are more setup details here: https://wordpress.com/theme/luxury/setup

    I hope that helps. Let us know if you have more questions!

  • The topic ‘Feature Page not working on Home page’ is closed to new replies.