Disable Comment Indentation

  • Author
    Posts
  • #72431

    I am not enjoying the way in which each comment related to a comment increases to such a degree that by the 5th comment or so, we have a single column of a word!

    How can I disable or modify this feature with css? I have been fairly successful at customizing a fair amount but, this one has me stumped!

    Please see the comments on this post to understand my concerns: https://nourishingourchildren.wordpress.com/2015/03/20/do-you-recommend-juice-plus-no/

    Thank you so much for your support!

    The blog I need help with is: (visible only to logged in users)

    #72534
    nourishingourchildren
    Member
    Original poster

    Oops! I think this may not make sense. I don’t want the indentation of subsequent comments, or replies to comments, to increase each time so that it results in a single column. I hope this clarifies!

    #72571

    Hi there!

    It is possible to reduce the indentation of each level of comment reply. The default rule in Snap is configured to only apply to wide screens (comments on mobile screens don’t get any indentation already). So you could try a rule like this:

    @media screen and (min-width: 900px) {
      #comments .children {
        padding-left: 18px;
      }
    }

    Or you could set that to 0 if you don’t want any indentation at all. You can also limit the depth that threaded comments can be nested, or turn off threading altogether:

    https://en.support.wordpress.com/settings/discussion-settings/#other-comment-settings

    #72572
    nourishingourchildren
    Member
    Original poster

    Thank you so much for your response! I had identified this css by using inspect element in Safari however I didn’t add the second } symbol that you have above and that seemed to make all the difference!

    @media screen and (min-width: 900px) {
    #comments .children {
    padding-left: 18px;
    }

    }

    I have chosen a bit more of an intent – 25 px so it is more apparent. I am so grateful!

    #72573
    nourishingourchildren
    Member
    Original poster

    By the way, I am working on an iMac with a 27″ widescreen display that is connected to an Apple Thunderbolt 27″ widescreen display by it’s side, and this is the result I got with the default settings, unchanged, which prompted me to ask this question: https://nourishingourchildren.files.wordpress.com/2015/03/comments.png

    These results were mirrored on my MacBook Pro.

    #72576

    Thanks for the feedback! I can see how having several levels of nested comments can quickly become a problem with the current indentation rules.

    #72584
    nourishingourchildren
    Member
    Original poster

    Yes! A one column response is not a very viable way to read. I was fairly concerned about this issue. If there wasn’t a fix, I would have not felt comfortable keeping this theme, which I just purchased so, I am grateful we could change the parameters.

  • The topic ‘Disable Comment Indentation’ is closed to new replies.