Custom font not working quite right and one other small matter

  • Author
    Posts
  • #43098

    enzo532blog
    Member
    Original poster

    Hi there,

    I am experiencing an issue with my blog that I have just switched over to Kent, I am using custom fonts, namely Chunk, for the post titles, but it doesn’t seem to be working as it should, particularly when using Google Chrome. Part of some titles are appearing in a different font.

    The problem seems to occur when there is punctuation in the title such as here:

    http://in-the-back-of-the.net/2013/11/23/new-zealand-footballs-got-talent/

    and here:

    http://in-the-back-of-the.net/2012/04/14/why-soccer-doesnt-suck/

    And this one also has a problem with the ‘e’ in c’è appearing in a different font regardless of what browser I use, it’s the same in IE and Safari (in Chrome the whole first two words look wrong):

    http://in-the-back-of-the.net/2013/12/10/non-ce-problema/

    I assume this is a bug in the theme that can be fixed at your end?

    Also, I just have one small style question, when I embed links into my posts, on my old antiquated laptop screen they are not standing out too well and I’m worried some people might miss them. Is there a CSS code I can use to bolden them up a bit?

    Thanks in advance for your help. :-)

    The blog I need help with is: (visible only to logged in users)

    #43197

    enzo532blog
    Member
    Original poster

    I thought it was just apostrophes causing the problem, but it seems commas do it too maybe:

    http://in-the-back-of-the.net/2013/10/13/summers-here-no-really/

    #43198

    enzo532blog
    Member
    Original poster

    Sorry to keep bombarding this but I keep finding more gremlins.

    Apostrophes also seem to be doing something weird with category archives. For example, still in Chrome, this one has everything but the name of the category in Chunk:

    http://in-the-back-of-the.net/category/national-womens-league/

    Whereas this one has the whole lot in some other font…

    http://in-the-back-of-the.net/category/roma/

    In IE all looks fine.

    #43200

    binarymoon
    Theme Author

    Hi

    I’ll start with the links since I can answer that one most easily :) The following custom css will make the links stand out more.

    #main article a {
    font-weight:bold;
    }

    For the fonts themselves – I am using Chrome on a Mac and the fonts look fine to me – apart from the è. The reason the è doesn’t work is simply that Chunk doesn’t support all foreign language characters as described on the Chunk info page on typekit.com – https://typekit.com/fonts/chunk

    I believe the issue is with the font/ typekit and not the theme. Have you tried any other fonts? Do they work better?

    #43201

    enzo532blog
    Member
    Original poster

    Thanks for your help.

    That code works perfect on the embedded links but it also makes all the post titles bold as well. Is there any way to keep the bold links but not bold the headings?

    When I play around with different fonts using the customiser the same problem doesn’t seem to exist so I assume you are probably right that the font is the problem. I really want to keep it though, there isn’t anything else that I like as much and according to my stat counter nearly 40% of my readers use Chrome. Can the issue be fixed? Is there somewhere else I should be raising the problem?

    Here’s a screenshot of how it looks to me using Chrome on a Windows PC: http://inthebackofthenet.files.wordpress.com/2013/12/screenshot.jpg

    Thanks again.

    #43202

    enzo532blog
    Member
    Original poster
    #43203

    binarymoon
    Theme Author

    for the code perhaps try this instead

    #main article .entry a {
    font-weight:bold;
    }

    Thanks for the screenshots. That helps show what you’re seeing nicely. I still have no idea what’s happening but it certainly helps clarify things. I think I may have to get the wp.com team to help since it’s to do with Typekit (I think) but before I do could I check that you’re using the latest version of Chrome?

    #43205

    binarymoon
    Theme Author

    Actually – another thing to try – if you go to this page (https://typekit.com/fonts/chunk) and then the Type Tester tab – enter some text in the box on the tab – do you see the same problems there?

    #43206

    enzo532blog
    Member
    Original poster

    Well, the excellent news is that code is exactly what I was after so that’s one issue resolved beautifully! :-)

    According to Windows my version of Chrome is up to date, it’s version Version 31.0.1650.63 m – but I’m having trouble confirming on the Chrome website that that’s the most recent version…

    Here’s a screenshot of my Type Tester tab – doesn’t seem to be displaying the same issue…

    http://inthebackofthenet.files.wordpress.com/2014/01/test.jpg

    #43207

    binarymoon
    Theme Author

    ok – I’m gonna call in the cavalry cos this is outside of my knowledge I’m afraid.

    #43208

    enzo532blog
    Member
    Original poster

    I thought of something else to try. I have another blog set to private I use to try things out before going live on my main blog. I put that onto the Twenty Ten theme and set the font to Chunk. No issues:

    http://inthebackofthenet.files.wordpress.com/2014/01/2012.png

    But when I set the same blog’s theme to Kent, the same issue:

    http://inthebackofthenet.files.wordpress.com/2014/01/kent.png

    So maybe this indicates that there is something about the Kent theme that Chunk doesn’t like?

    #43209

    enzo532blog
    Member
    Original poster

    Either way, it’s 2:30am here now so I’m off to bed and therefore won’t be able to respond to questions for a few hours. But I really do want to thank you for the super fast and nice way you have responded to all this badgering! It is much appreciated. :-)

    #43213

    enzo532blog
    Member
    Original poster

    Just a quick note to say I have tried a couple of other browsers. No issues in Firefox but the same problem as in Chrome also exists in Opera.

    #43217

    kathrynwp
    Staff

    Hi there, I was able to see the Chunk font issue in Chrome on Windows 7 when using Kent. It looks fine on Chrome 31/Mac, so the problem seems to only appear with the specific combination of:

    – Windows OS
    – Chrome browser
    – Kent theme
    – Chunk font

    I’ll bring this to our developers attention so they can have a look and see if we can find a solution. In the meantime, since we can replicate the issue on this end, please feel free to choose another font.

    #43228

    enzo532blog
    Member
    Original poster

    Also:

    Opera browser

    Thanks for that, it’s much appreciated. :-)

    Please let me know when the developers have done their thing.

    #43231

    kathrynwp
    Staff

    I will keep you posted here. We also noticed the same thing happens with a few other themes as well, so it’s not Kent-specific – there’s something about the Chunk font in combination with that browser/platform combination, only in certain themes.

    #43232

    kathrynwp
    Staff

    Could you let me know in what version of Opera you see the same issue? Thanks!

    #43233

    enzo532blog
    Member
    Original poster

    Thanks. It’s Opera 18.0.1284.68 running on Windows 7.

    I wasn’t going to mention it because it’s almost certainly a separate issue and almost nobody uses it, but it’s looking a bit messy on Opera’s iPhone browser too. Chunk isn’t showing up at all and the menu button and social media icons are showing up as white boxes with ‘x’ in them. I’m not really worried about it but just thought I’d let you know.

    #43234

    kathrynwp
    Staff

    Thanks for the info. We’ll focus on the desktop issue first and see if we can get that sorted. I’ll keep you posted.

    #43235

    enzo532blog
    Member
    Original poster

    Great, thanks again!! :-)

The topic ‘Custom font not working quite right and one other small matter’ is closed to new replies.