Creating a Blog Page not working

  • Author
    Posts
  • #150979

    We are using the Corporate theme for our web site (still very much in development). I tried to set up a “blog page” (using the default template) to use that for our News and Announcements section. Page is “News and Announcements”. However when I go to the page itself, it’s completely blank.

    I switched to the 2020 theme as a test and the blog posts showed up in News and Announcements as desired. This suggests that the problem is with the Corporate Theme.

    Can anybody help with what I need to do to set this up right?

    The blog I need help with is wp.asmicro.com.

    #151096

    mkrdip
    Theme Author

    Hi there,

    Please go to this page https://en.support.wordpress.com/pages/front-page/#3-create-a-blog-page-optional as described, please assign your homepage and News and Announcements page as your blog page. Then it’ll show up.

    Thanks.

    #151107

    As I said in the email response, I did that. I included a screenshot in the email. However, when I go to the actual blog page ( http://wp.asmicro.com/news-and-information/ ) I get a blank screen. Even “show page source” comes up empty.

    If I switch to a generic theme such as the WordPress 2020 theme, it works. The blog page comes up as normal. Thus:

    – Corporate theme: blog page comes up empty.
    – WordPress 2020 theme (no other changes): blog page comes up as normal.

    This strongly suggests that something about the Corporate theme is interfering with the proper operation of the blog page on our site.

    #151145

    Okay, the email was a “noreply”. Missed that. Since this forum doesn’t seem to allow attachments that I can see let me try this. You can see the screenshot image at:
    Image saved on Google Drive

    If you look at it you can see that I did what the WordPress support link instructs. I still get the exact same issue: blank page with no content whatsoever. “View Page Source” also comes up completely blank. However when I switch to a generic theme like WordPress 2020 the blog page comes up fine.

    #151336

    mkrdip
    Theme Author

    Sorry for being late. I replied to everything you wanted via email. Please check and let me know.

    Thanks!

The topic ‘Creating a Blog Page not working’ is closed to new replies.