Comments

  • Author
    Posts
  • #109368

    chelstee
    Member

    Hello!

    Two of my pages are adding comments even though I did not click that option. All the others are fine. Not sure why these are different, do you know how I can fix it? I do not want commenting possible for any of my pages or photos.

    For an example, see the Little Roseberry page on my website.

    The blog I need help with is chelseagipson.com.

    #109470

    themetrust
    Theme Author

    Hi,

    I’m not seeing any comments on that project page.

    #109636

    chelstee
    Member

    Hello,

    It’s under the photos, see this link for an example:

    https://chelseagipson.com/portfolio/little-roseberry/#jp-carousel-73

    #109654

    themetrust
    Theme Author

    Still not seeing any comments or comment field on that page.

    I’m tagging this topic for a WordPress support staff member to look at. Someone should reply shortly.

    #109655

    kathrynwp
    Staff

    Hi there – the easiest way to prevent commenting on carousel images is to add this custom CSS:

    #jp-carousel-comment-form-container, div.jp-carousel-buttons a.jp-carousel-commentlink, #jp-carousel-comments-loading {
      display: none;
    }
    .jp-carousel-buttons {
      padding: 0;
    }

    There’s also a way to close comments on each image manually, but it’s a lot more work. You would need to go into your Media Library, choose a specific image, click the “Edit More Details” link, uncheck Comments and Save. If you don’t see the Discussions box in this view, click “Screen Options” at the top right and check it off to display it. (Source)

    The CSS route is easier. :)

    Let me know how it goes!

    #109677

    chelstee
    Member

    Hello!

    This still didn’t work. I don’t know why but all photos under the Little Roseberry link still show a comments section.

    I tried to go in and do it the other way mentioned but I couldn’t find a “Edit More Details” link.

    Any other ideas?

    Thank you for your help!
    Chelsea

    #109678

    kathrynwp
    Staff

    Hi Chelsea! Looks like we need to bring out the !important hammer to override a new inline style that’s causing the original CSS I gave you not to work. Could you remove this part I gave you before:

    #jp-carousel-comment-form-container, div.jp-carousel-buttons a.jp-carousel-commentlink, #jp-carousel-comments-loading {
      display: none;
    }

    And replace it with:

    #jp-carousel-comment-form-container, div.jp-carousel-buttons a.jp-carousel-commentlink, #jp-carousel-comments-loading {
      display: none !important;
    }

    We usually try to avoid !important wherever possible, but it’s necessary here. Let me know how it goes!

    #109679

    chelstee
    Member

    Hello!

    This one worked, thank you so much!

    Chelsea

    #109680

    kathrynwp
    Staff

    You’re welcome, glad that did it!

The topic ‘Comments’ is closed to new replies.