Caption underlining and missing homepage button

  • Author
    Posts
  • #127908

    bookwives
    Member

    How can I add to the menu the point “homepage”? If someone is reading a blogpost, I can’t find any possibility to get back to homepage with only one click.
    And pictures with a caption have the caption underlined. How can I remove this lining?

    Thank you!

    The blog I need help with is bookwives.de.

    #128014

    bookwives
    Member

    Ah, the homepage button I have now. :)

    #128022

    emilysuesrq
    Theme Author

    Okay, so do you still need further help with the homepage, or is it resolved?

    To hide the underline on photo captions, add the following CSS into the Additional CSS section in the customizer:

    .wp-caption .wp-caption-text {
      border-bottom: 0;
    }

    I hope that helps! Let me know if you need help with the home page :)

    -Emily

    #128026

    bookwives
    Member

    Hi Emily,

    thanks for your help. It works! *happyme*

    I have one more thing: I shorten the posts with “continue reading” on the homepage.
    How can I revise colour of “continue reading”?
    https://snag.gy/uZcLie.jpg
    It’s barely readable.

    And I have problems with the header. Although image is in suggested size, it doesn’t fit. But in preview mode it is ok.
    Preview: https://snag.gy/oXDtIv.jpg
    Real: https://snag.gy/vxiWNt.jpg
    And on mobile devices it is cut off on the sides. But I have also asked a staff member of WP. But probably you know?

    #128073

    emilysuesrq
    Theme Author

    Glad that helped!

    1) To change the text color on the buttons:

    a.more-link, a.more-link:link, a.more-link:visited {
     color: white;
    }

    2) For the header image:

    #custom-header .header-img {
       min-height: 220px;
       background-size: contain;
       background-position: bottom center;
       background-repeat: no-repeat;
       background-color: #FCFCF2;
    }

    Let me know if you need further assistance. Thanks.

    -Emily

    #128084

    bookwives
    Member

    Emily,
    that’s great. Thanks. The first tip was very good.
    I did the second one, but now I have a white frame on the left and on the right of the header image:
    https://snag.gy/tEGpIU.jpg
    Shall I upload the image in another size again?

    Checking it on my mobile, I have a white frame above the header now:
    https://snag.gy/BkVq5l.jpg

    -.-

    #128120

    emilysuesrq
    Theme Author

    Within the code you added before, please replace the color, next to “background-color” with this: #fbf9ed

    To resolve the mobile issue, please add the following:

    @media handheld, only screen and (max-width: 1023px) {
      #custom-header .header-img {
         min-height: 160px;
      }
    }

    You may need to adjust the min height number, test it out and you will see. I hope that helps, let me know if you need anything else!

    #128122

    bookwives
    Member

    Emily thanks again. This helps.
    But unfortunately on a computer it looks like, as the image has a missing part on the right side.
    https://snag.gy/Rk8OCb.jpg

    :/ I feel really helpless.

    #128169

    emilysuesrq
    Theme Author

    I see what you mean, but it seems like this is the image itself. Is it possible it could have been cropped this way from the beginning? Otherwise, you can re-upload the full original image (make sure the original image doesn’t have that missing part)… let me know!

    We’ll get it figured out, don’t worry. Thanks for your patience.

    #128180

    bookwives
    Member

    Hi Emily,

    thank you for your patience. :)

    First I have uploaded the image, as it was written in the theme information. But it was too big somehow. So we cropped it.
    Afterwards I had these problems and just now a staff member of WP says, it should be in size 1096 x 493. So my friend changed the image again. But this doesn’t seem to fit. -.-

    #128267

    emilysuesrq
    Theme Author

    When you view the image before it is uploaded to the theme, it appears normal?

The topic ‘Caption underlining and missing homepage button’ is closed to new replies.