Can't get rid of Widgets, Video sizing

  • Author
    Posts
  • #16224

    Hey,

    I was really happy to find your theme that is so video friendly, but I’m having two problems right now…

    First: I can’t seem to get rid of the widgets on my page. Despite pulling the “search”, “archive” and “meta” tags out of the sidebar and footer areas completely (they are all empty) I still have the widgets on my pages taking up a third of my page. I have no use for these functions and just want my videos displayed without any distraction or unnecessary garbage on the page. This goes the same for “Post” that come up with “Author” and “Dates” on them, is there anyway to get rid of that stuff?

    Second: How do I get the videos to appear larger on the screen, like in your demo? Right now mine are appearing right justified, as opposed to centered, and seem like about half the size they could be to maximize the sites viewing space. And depending on the video post the size is all different for viewing. Plus all the videos on the “Showcase” page are all different sizes and shapes and so the bottom showcase bar looks like a mess versus neat and organized. I’m assuming this has something to do with some are cropped for 16×9, others for 4×3, which I’m assuming I’ll have to make uniform with the video clips before I add the URL.

    Any thoughts to help me with these problems?

    Thanks.

    The blog I need help with is: (visible only to logged in users)

    #16373
    vailobox
    Theme Author

    Hello!

    We are required to provide a default sidebar for those who do not add widgets under Appearance > Widgets. If you do not want any sidebar content, add a blank text widget and enter a blank space in the title field.

    For the post meta, you can hide those elements if you have access to the CSS tab under Appearance > Custom Design. Add the following:

    .post-meta{display: none;}

    For larger videos, you need to encode and upload large format or HD video using the same aspect ratio, then ensure your embed code reflects the HD version (Vimeo tends to have better display/options for this). If you are referring to the full-width video on the showcase, ensure you have created your Showcase page (read the how-to)

    You are correct in that the various iframe sizes and aspects are causing the videos to look un-uniform.

    #16520
    trevorcornish
    Member
    Original poster

    Thanks for the feedback. I tried your “add a blank text widget and enter a blank space” idea, which did make the visual of the “search” widget (along with the Meta and archive) go away. But the space, that 1/3 of the screen, is still just left there, now blank, but still taking up the right side of the screen and leaving all images, or video in my case, left justified. I tried the same “add a blank text widget…” idea to the Footer Area One, Area two sections, in a hope that this would then shift all this stuff to the bottom of my page, where a little bit of extra blank white space would go unnoticed, but this just left me with two widget areas, one a sidebar, the other a footer. I’m guessing you just can’t make this stuff go away and not take up any real estate on the page?

    I tried the CSS tab thing to get rid of the “Meta”, but it didn’t seem to work. I copy and pasted your code in to the Custom Design CSS tab and saved it (after it saved it took your code and broke it up over three lines. I not sure if this is what it is supposed to do, but I tried it several times and the same result). But either way, the “Meta” field was still there. Not sure what I’m doing wrong there?

    I’m trying to resize all my videos to be HD so that they’ll more uniformly display on the showcase page. But I’m still have some problems with the way the thumbnails are being seen in the showcase bar. I get that you can put them in order based on the post dates you assign them, but they are still laying out very scattered. For instance 4 images on the top row (like it’s supposed to be) then 2 on the next row, but positioned off to the last right 2 spaces. Then 1 on the next row, far right space, and 1 on the next row, far left space. This is how my page is currently laid out if you wanted to see it. I keep shifting things around, but the 8 elements don’t seem to want to line up, 4 on one row, 4 on the next. Any thoughts here?

    Thanks again for any help you can offer.

    #16535
    vailobox
    Theme Author

    Hi Trevor,
    Unfortunately themes here can only be customized to the extent that CSS allows. Removing the sidebar or changing layouts are beyond the scope of our support here, so I would recommend exploring a self-hosted WordPress site where you can edit the theme templates at will.
    Here are a few things that may help (add to the Cusom CSS:)

    .single-format-video .hentry {
    width: 960px !important;
    }

    For your showcase, are you using embed code or oembed links? Please ensure all of your posts contain the video link in the body (Example: http://www.vimeo.com/49287491), not embed codes, and have the Video post type selected.

  • The topic ‘Can't get rid of Widgets, Video sizing’ is closed to new replies.