Broken formatting on pages, archives and posts

  • Author
    Posts
  • #154531

    Several elements on pages and posts are displaying … oddly.

    1> On the social menu, odd symbols are appearing between several of the icons.

    2> The image of the book cover appearing below it, and the caption accompanying it, are justified to the left of the margin.

    3> The indenting I have setup in CSS for post content is lost.

    I deleted *all* the custom CSS, and the error still occurs in the social menu and widget

    I’ve tried removing the social menu and text widget individually and together, but this had no effect on the content.

    I’ve tried removing every widget in the sidebar … still the characters appear in the social menu and the content area is mis-formatted.

    I’ve also tried analyzing the page source, but whatever’s causing this is beyond me.

    Help!

    The blog I need help with is pixtowords.com.

    #154555

    alinclamba
    Theme Author

    Hey,

    Let me take care of the issues you’re facing one by one.

    #1. On the social menu, odd symbols are appearing between several of the icons.

    Thanks for the heads-up. We’ll fix this in the next theme update, but until then, you can use the CSS below:

    
    .nav--social a {
        color: transparent !important;
    }
    

    #2. The image of the book cover appearing below it, and the caption accompanying it, are justified to the left of the margin.

    For this one, the CSS below should do the trick:

    
    @media only screen and (min-width: 900px) {
       .aligncenter, .aligncenter.wp-caption[id*=attachment][class][class] {
            margin-left: 30px;
       }
    }
    

    Let me know if it helps.

    Alin
    Pixelgrade

    #154607

    That worked. Thanks!

    It didn’t resolve the failed margin in the post body, but I switched it from margin to padding in the CSS and now it at least renders as I would expect it to.

The topic ‘Broken formatting on pages, archives and posts’ is closed to new replies.