"Blog" link on menu, when clicked, only shows the featured image-not blog post

  • Author
    Posts
  • #92523
    edup12205
    Member

    I’m trying to create a link in my Menu to take people straight to my blog. I have set it to the categories correctly, and when I click on my newly added “Blog” menu item, it only shows a list of the featured images–not the posts themselves. I can click on the photos to take me to the individual blog posts, but that defeats the purpose. Is there a setting somewhere that I have missed? I just want a scrolling blog with a featured photo and a summary or excerpt, not another link to each post. Does that make sense? http://www.erindupreephotography.com

    The blog I need help with is: (visible only to logged in users)

    #92632
    rezzap
    Staff

    Hello!

    Instead of adding the category to your blog, add the page you’ve set as your ‘post page’ and this will show the blog roll instead of the category list.

    Thanks!

    Rebecca

    #92637
    edup12205
    Member
    Original poster

    Sorry for the confusion, but can you explain it a bit better for me? I have created a new page, named it Blog, then in the menu option I added it, and in the drop down menu I set it to show categories. I’m not so great at learning through reading, so it may be going a bit over my head–sorry!

    #92654
    rezzap
    Staff

    Hello!

    You’ll need to follow these steps:

    1) Create a new page for your blog (name is blog).
    2) Navigate to Customize > Static Front Page and assign this page to the Post Page from the options shown there.
    3) Navigate to customize > Menu > Add New Item and add the Blog Page to your menu. Once you select the + sign to add a new menu item, there will be various tabs on the left. One of these (which should be the one already open) is ‘Pages’. Select the Blog page from here to add to your menu. Do NOT select the category.

    Thank you!

    Rebecca

    #92841
    edup12205
    Member
    Original poster

    Hi again. Thank you for your advice. Unfortunately, I think we may be misunderstanding each other. I already have my Home Page set to a Slideshow, as I intended. The issue I am having is that I can’t get my blog posts to appear on a Separate Page (which I am trying to add to my menu as ‘Blog’–though it’s currently called ‘Sessions’ in the menu.) What happens is that I can add my “Blog” page to the menu, and it will only show the featured photo of each blog post. Here is a link to the exact page to show you what I mean: http://erindupreephotography.com/category/sessions/

    In that page, you will see a list of photos, each of which is a link that will take you to the blog post that relates to the photo you have clicked. I am trying to figure out how to make this Page in the menu like a traditional scrolling blog, with the blog post title, excerpt from the post, and a featured photo.

    #92842
    edup12205
    Member
    Original poster

    The example in the live demo of the theme is what I’m trying to accomplish with my own website, exactly: https://photographerdemo.wordpress.com/blog/

    #92843
    rezzap
    Staff

    Hello,

    The page is displaying as such because instead of adding the blog page to the menu, you have added the category. To create a blog page you will need to follow the steps I mentioned above and then add the page to the menu instead of the category. You can name the page ‘Blog’ or ‘Sessions’ but this page must be assigned as the ‘Post’ page under Customize > Static Front Page.

    Try following the steps I provide above (this has nothing to do with your front page) and you’ll see your blog page appear as in the demo. :)

    Thanks!

    #92856
    edup12205
    Member
    Original poster

    Hi again! Thank you for patience with me. :) I figured it out, thankfully! The customizer was showing me the correct results, but for some reason I was thinking that the changes were being made to the front/home page.

    Thank you!

    #92862
    rezzap
    Staff

    Glad to hear you got it sorted. :)

    Let us know if we can help with anything else.

    Thanks,

    Rebecca

  • The topic ‘"Blog" link on menu, when clicked, only shows the featured image-not blog post’ is closed to new replies.