Big Slider Widget Size

  • Author
    Posts
  • #94690

    paulmozina
    Member

    Hi Shroote.

    I reviewed this forum thread https://premium-themes.forums.wordpress.com/topic/big-slider-image-sizing?replies=5 regarding resizing the big slider.

    The site is https://patiholman.com/

    When I uncheck the “Make it 100% wide” checkbox in Homepage widgets: Homepage Big Slider, the Big Slider widget no longer appears on the index/homepage.

    I currently only have 1 post marked for the Big Slider and I tried making the featured image smaller to give it room to fit alongside the sidebar but that did not work.

    The site is currently in the state where the Big Slider widget is not visible, but this widget is still configured as the first widget on the index/home page. If I check the Make it 100% wide box, it will reappear in 100% width. How do I get it to resize per the example in http://www.pedlas.com/?

    thanks!

    #94925

    paulmozina
    Member

    It looks like WordPress is not even attempting to render the Big Slider Widget when the “Make it 100% wide” checkbox is unchecked. Here is the executed code as shown by the debugger. The processor begins work on the second widget on the homepage skipping the Big Slider.

    </header>
    <!-- #masthead -->
    <div id="main" class="site-main">
    <div id="primary" class="content-area">
    	<div id="content" class="site-content" role="main">
    		<div id="default-sidebar" class="sidebar-container">
    			<div class="widget-area">
    				<aside id="wpshower_index_highlights-2" class="widget widget_wpshower_index_highlights">
    		<article>
    			<h5 class="widget-title">Events<span class="next">></span><span class="prev"><</span><span class="bullets"></span></h5>
    <ul class="slides">
    
    <li>
    <article>

    etc…

    When I check the “Make it 100% wide” checkbox, the processor renders the Big Slider.

    </header>
    <!-- #masthead -->
    <div id="main" class="site-main">
    <div id="slider" class="outspoken-gallery uncropped">
    <ul class="slides">
    
    <li>
    <article><a href="https://patiholman.com/2016/02/22/what-are-the-nine-essentials/" title="WHAT ARE THE NINE ESSENTIALS?"></a>
    <div class="info">
    <div class="meta"><span class="categories-links"><a href="https://patiholman.com/category/blog/" rel="category tag">Blog</a></span>
    </div>
    <h2><a href="https://patiholman.com/2016/02/22/what-are-the-nine-essentials/">WHAT ARE THE NINE ESSENTIALS?</a></h2>
    </div>
    </article>
    </li>
    <div class="prev"><</div>
    <div class="next">></div>
    <script type="text/javascript">
    		jQuery(function() {
    			jQuery('#slider').wpShowerSlider({
    				autorotate: 10			});
    		});
    		</script>
    </div>

    I have left the “Make it 100% wide” checkbox CHECKED at the moment so the Big Slider is appearing. Let me know if you want me to uncheck this option for purposes of debugging.

    Thanks for you help!

    #94927

    paulmozina
    Member

    sorry, formatting the code got messed up, I hope the point is clear

    #94949

    paulmozina
    Member

    We are developing the site in parallel on WordPress.org hosted by GoDaddy. There, simply unchecking the “Make it 100% wide” checkbox positions the Big Slider exactly where/how we want it. See this screenshot https://dl.dropboxusercontent.com/u/70223658/BigSliderPositionedCorrectly.tiff This is exactly like the example on http://www.pedlas.com/

    Can this feature be made to work on WordPress.com?

    Thanks

    #94968

    shroote
    Member

    Hello,
    I fixed your post, formatting is fine now. Just checked that option locally and on my wordpress.com private test site, it works fine, this is weird. Do you have another big slider in “Inactive widgets” by any chance?

    #95004

    paulmozina
    Member

    Hi Shroote. Sorry for the delay getting back to you, I was out of town.

    I still see the same behavior. Right now I have the “Make it 100% wide” box unchecked and the the Homepage Big Slider widget is not appearing on the Homepage. I again verify that checking this box does make it appear 100% wide, but unchecking it does not resize it to fit next to the sidebar. Here is the site https://patiholman.com/ sans Homepage Big Slider.

    We appreciate your support. Pati would like to go live with the new site on June 1 when our current hosting contract expires.

    paul

    p.s. when you say “I fixed your post, formatting is fine now.” Please let me know what you were referring to. Did you notice something else amiss?

    #95006

    paulmozina
    Member

    Shroote, sorry, forgot to address your question. No, we do not have another Homepage Big Slider in the inactive widgets area.

    paul

    #95011

    paulmozina
    Member

    Hi Shroote. I hope you will help us resolve this open issue. It may be working on your private test site, but it is not working on our site. What could be going wrong in our case?

    Thanks

    #95012

    paulmozina
    Member

    ok, we are porting this site from an existing site that has a page called Homepage. I set the template on this page to Magazine and on the Settings|Writing panel, I indicated this was the static Front Page.

    This change fixed the problem with the Big Slider resizing to sit alongside the siderbar when the “Make it 100% wide” checkbox is unchecked. That is cool and what we want.

    But there is still something I am not understanding about how the configuration of the HomePage or Index page works. The HomePage that I selected as the static front page does include a couple paragraphs as it is the homepage on Pati’s existing site at http://www.feldenkraismilwaukee.com (the one we are porting to Outspoken). None of the content on this page appears when rendered as the static front page in the Outspoken theme. Instead of the content, a list of 10 blogs appear under the page heading “HomePage” (because this is in fact the title of the static page used for our homepage) Please see for yourself by scrolling down past all the widgets on this page http://www.patiholman.com (please note, this is a work in progress).

    We would prefer to NOT have a Page Header with the label “HomePage” (the title of the underlying page) beneath all the widgets nor to have it show a list of blogs.

    What am I doing wrong here? I am going to review the forum entries and Outspoken documentation to see if I can figure it out. Any advice is welcome.

    paul

    #95013

    paulmozina
    Member

    By picking a post category option for the Homepage I find I can control the number of posts that are shown under the Homepage title at the bottom of the screen — just above the footers.

    So, to summarize, if we DO NOT specify a static front page, then the “Make it 100% wide” checkbox does not function correctly if it is unchecked. Unchecking this box makes the Homepage Big Slider disappear.

    If we do select a static front page then we can resize the Home Page Big Slider and get it to fit alongside the sidebar like we want, but, we then get that static Homepage displayed beneath all of the HomePage Widgets. In our case the actual content of the page is ignored and instead, it uses the post category option associated with the page to display a list of posts.

    We would prefer to NOT use a static front page. Shroote, can you please investigate why unchecking the “Make it 100% wide” box when NOT using a static front page, makes the Homepage Big Slider widget disappear?

    Thanks!

    #95018

    shroote
    Member

    Hello,

    I just retested big slider with “Make it 100% wide” checkbox both enabled and disabled, seems to work fine for me. I tested with “Front page displays” set to “Your latest posts” and “A static page” with “Blog”, “Magazine” and “Masonry” templates. Basically “Your latest posts” displays homepage widgets only, “Blog”, “Magazine” and “Masonry” front pages display homepage widgets + some differently formatted posts. Any other template for front page won’t have homepage widgets. I’m really lost as widget never disappears for me, can you try this on another clean WordPress installation?

    #95019

    paulmozina
    Member

    Thanks for investigating this Shroote.

    We did try this on a clean WordPress.org site per this entry I made above:
    “We are developing the site in parallel on WordPress.org hosted by GoDaddy. There, simply unchecking the “Make it 100% wide” checkbox positions the Big Slider exactly where/how we want it. See this screenshot https://dl.dropboxusercontent.com/u/70223658/BigSliderPositionedCorrectly.tiff This is exactly like the example on http://www.pedlas.com/

    Since then we have replaced the code hosted on GoDaddy with the code from Pati’s existing site at http://www.feldenkraismilwaukee. I don’t think we will be ready to bring up here new site here on WordPress.com using the Outspoken Theme by June 1 so we are planning to bring up here existing site live on GoDaddy (is is working perfectly in a temporary domain) while we complete construction of her new site with Outspoken.

    I just verified that setting the front page to show latest posts via Settings|Reading still results in the Homepage Big Slider widget NOT displaying when the “Make it 100% wide” box is unchecked. That is the current state of the site at http://www.patiholman.com. Let me know if you want me to make any changes to assist the debugging process.

    I understand now why when you pick a static front page it automatically displays posts of the category you select for that page. That makes perfect sense.

    I will try to see what I can see using the Firefox developer debugger tool. Shrooote, do the folks at WordPress.com allow you any access to the backend to enable you to use more sophisticated debugging tools?

    thanks

    #95020

    paulmozina
    Member

    fwif, I turned on the console view in the Firefox developer tools and captured the difference between when the Big Slider displays and when it does not. The differences shown in the files I am linking to on Dropbox occur at the end of the console log output (there are no differences in the two console outputs until the starting line in each of the files below).

    https://dl.dropboxusercontent.com/u/70223658/ConsoleDisplayWhenBigSliderWidgetNotVisible.txt

    https://dl.dropboxusercontent.com/u/70223658/ConsoleDisplayWhenBigSliderWidget100Wide.txt

    There are 13 additional lines of output shown when the big slider does not display — more errors and warnings. Maybe comparing the differences will reveal some clue.

    Can we engage the WordPress.com support team to take a look?

    Thanks Shroote!

    #95021

    shroote
    Member

    No problem. I have no way how to debug theme on wordpress.com, even on my own account. Output from developer tools doesn’t help at all, this is not frontend issue as there’s no html for big slider widget. I’ll write mail to support team about this, maybe they’ll have some idea. If you’re up for it ask about this also.

    #95022

    paulmozina
    Member

    Ok, I will send support request to WordPress.com too.

    Thanks Shroote

    #95024

    paulmozina
    Member

    I got this from Herman at WordPress.com Support:

    “It appears that you have set the Homepage Big Slider widget to only be visible on pages where Pati is indicated as the Author of the page. As the default home page display a list of the latest posts it technically doesn’t have an author, which is why the slider won’t appear.
    https://cloudup.com/cVB6gChOZpH

    To fix this, open the Customizer and edit the widget. Click the Visibility button and delete the current visibility setting. That should make the slider appear.

    Please let me know if you need any more help with this.”

    I made the change Herman suggested and that did fix the problem! Wow, I did not even notice the visibility button or consider it could be having an impact. The Homepage Big Slider is working perfectly now on http://www.patiholman.com.

    Thanks to WordPress support and to Shroote for investigating this.

    Herman – Happiness Engineer

    #95025

    shroote
    Member

    You’re welcome, glad this is resolved at last.

The topic ‘Big Slider Widget Size’ is closed to new replies.