Autoplay Video on Mobile

  • Author
    Posts
  • #162930
    nicolewoods1
    Member

    Hi, again!
    I’m having difficulty with the first video on this page: https://nicolewoods1.com/digital/

    The video is set to loop and autoplay, but it does not do so on mobile.

    The video is hosted on my site, but I have compressed it so that the file size is 3.1MB and the resolution is 1280 x 720. On Chrome developer tools and in the Profile theme preview when “phone” is selected, the video plays. However, on actual smartphones, it does not.

    Here is the direct URL for the video from my media library: https://videos.files.wordpress.com/UdrwGqVN/interactive-digital-touch-wall-with-users_mp4_hd.mp4

    Here is additional information about the video file:
    General:
    File type: .mp4
    Resolution: 1280 x 720
    Data Size: 3.1MB
    Video Format: H.264
    Audio Format: AAC, 48000Hz

    Video Details:
    Encoded FPS: 23.98
    Data Rate: 2.27 Mbit/s
    Aspect ratio: 16:9
    Current Scale: Actual size
    Track ID: 1

    Audio Details:
    Language: Unknown language
    Channels: Stereo (L R)
    Track ID: 2

    Thanks in advance for your help!
    Nicole

    The blog I need help with is: (visible only to logged in users)

    #162952
    itsdavidmorgan
    Theme Author

    Hi Nicole,

    Thanks for reaching out. I believe this is a restriction of the WordPress platform in mobile. Meaning, WordPress disables video autoplay features in mobile.

    When viewing the console while inspecting your site, the following warnings are visible:

    • Autoplay is only allowed when approved by the user, the site is activated by the user, or media is muted.
    • Uncaught (in promise) DOMException: The play method is not allowed by the user agent or the platform in the current context, possibly because the user denied permission.

    I’ve tagged the WP staff in this post. However, there is no change we can make on the theme end to make the video autoplay in mobile.

    Thanks!

    #162953
    nicolewoods1
    Member
    Original poster

    Thank you for looking in to this and tagging WP staff!

    I thought that by upgrading to WordPress Business plan and activating JetPack would allow the video to play, and I tried to follow the directions on VideoPress closely, but the issue persists.

    Also, just want to point out that there are two other video files on the same page of my site [https://nicolewoods1.com/digital/] that I coded the same way, which DO autoplay on mobile, which is another reason for my confusion.

    Thanks!
    Nicole

    #162956
    itsdavidmorgan
    Theme Author

    No problem. :)

    Ah, interesting the other videos do autoplay in mobile. In that case, it may be an issue where the WP Staff can provide further assistance.

    Thanks!

    #163125
    nicolewoods1
    Member
    Original poster

    Hi, there, David. You mentioned tagging the WP staff in this post, but I haven’t seen anything come through from them. Do you recommend a way I can get in touch with them?
    Thanks,
    Nicole

    #163152
    itsdavidmorgan
    Theme Author

    Hi Nicole,

    You could try reaching out to a Happiness Engineer here, https://wordpress.com/help/contact/

    Thanks!

    #163179
    nicolewoods1
    Member
    Original poster

    Thank you, David! That worked and the issue is now resolved!

  • The topic ‘Autoplay Video on Mobile’ is closed to new replies.