Audio Player/Sound not working on Windows Computers

  • Author
    Posts
  • #87865

    rcmadmin
    Member

    Hey there,

    I looked through the forum for a solution. If it is previously answered and I missed it, my apologies. I am having issues with audio playing on any Windows computer. I’ve been working via Apple products with no problems.

    For example:
    http://monteverde.fm/2015/12/01/chorreando-cafe-6-con-kay-chornook/

    When on a Windows computer, everything is set up and looks great. However, the player and/or sound is disabled. The audio will load and one is able to skip to any part of the interview. That is all though, no sound.

    I’ve checked sound levels and both Windows computers had iTunes or another media player.

    Any help is greatly appreciated! Like I said, works great on all Apple products.
    Thank you

    The blog I need help with is monteverde.fm.

    #87999

    thelukemcdonald
    Theme Author

    Can you let me know what version of Windows you’re using and what browser and version you’re using.

    #88007

    rcmadmin
    Member

    Yep!
    3 different computers

    Radio Station Desktop: Chrome (Version 47.0.2526.106), up to date everything. Windows 7. iTunes. VLC media player

    Laptop #1: Chrome browser, up to date (47). Windows 10, no iTunes

    Laptop #2: Chrome browser, up to date (47). Windows 8.1, yes iTunes

    #88012

    thelukemcdonald
    Theme Author

    I did some testing on Windows. In most cases, it’s up to the browser to handle the audio and not necessarily the operating system.

    I was able to play the audio on your website using the player in the left sidebar of the homepage. This tells me the audio player in the theme works on Windows machines. That said, the audio on the post your provided does not work for some reason.

    To make sure the issue isn’t with a player on single post pages, I tested this post in the theme demo and the audio worked for me. Does the audio work for you?

    There are a few things we can try to get a better understanding of what might be going on or where the problem lies.

    1. Can you turn off the sharing icons for the post you linked to. I see two Javascript errors on that page related to Twitter. Twitter recently changed their API and no longer show tweet counts, which is what the errors are related too. I don’t think this is the problem, however, it’s something to eliminate.

    2. Can you try creating a new audio post and uploading a new .mp3 to test? Does the audio work?

    #88045

    rcmadmin
    Member

    Hey there,
    Sorry for choppy communication. We’re really busy down here.

    Yes, I should have mentioned that the front page/first column audio works on all of the Windows computers we tried.

    1. Hopefully, the sharing icons aren’t the issue. That was one of the main reasons we picked this theme. I did turn it off for that particular post. However, would like to turn them back on as soon as possible.
    Update: I turned off the sharing for this post (http://monteverde.fm/2015/12/01/chorreando-cafe-6-con-kay-chornook/) and the media player is doing exactly what it does on Windows, but from an Apple product. Audio is loaded and there, but does not play.

    2. I uploaded a new audio post. It won’t be published for a few days. Waiting on the complete post with picture. It is uploaded to that particular post. It all worked great.

    Is there any way you can access our account/computer remotely? My apologies, this is not my forte at all. The guy who helped design our specific website with your theme is traveling right now. He can be reached, kind of ((redacted) ).

    Again, thank you so much for the quick responses! Monteverde.FM is looking forward to resolving this issue as soon as possible.

    #88047

    thelukemcdonald
    Theme Author

    The social sharing icons are not part of the theme but rather a feature WordPress.com offers and would need to fix.

    As far as the audio goes, it sounds like there may be a problem with the audio file itself if it’s not playing in Browsers on Mac and PC. That said, the audio worked for me on a Mac using Safari, Chrome, and Firefox; I haven’t tested a PC yet. It did take a few seconds to load the audio and start playing, which can happen if when the audio file is large (usually long in length). In this case, sometimes it can be helpful to break the audio up into smaller files (like chapters). That is not always desired, but for larger files, it will help.

    That said, can you let me know if the audio works for you in the theme demo. I provided a link to a page to test.

    Also, it would be helpful to test other browsers.

    #88048

    rcmadmin
    Member

    Ok, gotchya. Are you saying it may be a WordPress problem? Should I try contacting someone else? Will you point me in the right direction if this is the case?

    All audio files are mp3. All worked on my personal mac before I turned off the share icon on that one post. Now, on that one post, it does not work on a my MacBook Pro via Chrome. It does wok on Safari. The above post also works on my iPhone 6 via Safari. That doesn’t sound like an audio file problem. It sounds like a WordPress/share icon/theme situation.

    I just tried a radio station laptop with Windows 7 and up to date chrome and it still doesn’t work, regardless of the share icons being turned off.

    I understand what you are saying about large audio files. Like I said previously- loading audio isn’t the issue. The gray bar loads (yes, sometimes slowly depending on the size) and you can skip ahead to say minute 3:59, it just won’t play.

    Yes, awesome! The Soundcheck theme demo works on the same Windows computer. That gives me hope :) However, Monteverde.FM is still in an unfortunate situation, at the moment.
    Again, greatly appreciated!

    #88094

    thelukemcdonald
    Theme Author

    The social sharing script errors is a WordPress problem and something they will need to fix and will likely have a fix in the near future. In anycase, it doesn’t sound like the social sharing icons are the issue.

    Because the audio on your site works and because the audio in the theme demo works, it sounds like the issue may be related to the audio file being used with the post you’ve linked to. I’d recommend removing the audio file for that post and upload a new version of the file. Make sure the file is encoded correctly. It will also help to upload a different file to make sure things are working.

    It would also help to create another audio post with a separate file to test. You can do this and delete the test post after we’re finished.

    #88216

    rcmadmin
    Member

    thelukemcdonald:
    We have done some further testing. We have successfully played audio files on a Windows computer running Firefox, but the audio does not work on Windows/Chrome. In addition, we are starting to see similar problems on some Mac computers running Chrome, but these problems are not seen running when running Firefox on a Mac. Our audio files are uploaded directly to posts, needed to utilize SoundCheck’s custom audio player. Is there any browser-specific code in the custom audio player which might be causing a problem with Chrome? Thank you for your help.

    #88218

    thelukemcdonald
    Theme Author

    I’m not exactly sure what the issue could be, because the audio on the theme demo plays in Chrome on either machine. I know sometimes browser can make updates that can cause some breakage at times, but in this case, one site can play the audio in Chrome while the other can’t.

    That said, the audio in the audio player widget on your homepage works in Chrome, but the audio for that post on the single page doesn’t. They both use the same scripts. So, something on the single audio pages must be causing issues with Chrome.

    There are two things different on the single audio page than the homepage.

    1. Audio Player in content area.
    2. JS notices for the Twitter Widget.

    Use the following page for testing: http://monteverde.fm/2015/09/14/front-page-audio/

    1. I’d like you to remove the audio player for the content are of the above page. Update page.

    Does it work in Chrome now?

    2. No? Disable the social media buttons from that page.

    Does it work in Chrome now?

    3. No? Use the old WP admin, go to Posts, find your post, and click the blue “Update” button. You can access the old WP admin by adding “/wp-admin/” to the end of your URL like so:

    http://monteverde.fm/wp-admin/

    Does it work in Chrome now?

    If it still doesn’t work, we’ll need to dig a little deeper because single audio posts in the theme demo work in Chrome.

The topic ‘Audio Player/Sound not working on Windows Computers’ is closed to new replies.