Audio player muted in IE and Firefox

  • Author
    Posts
  • #29697

    dshrumm
    Member

    I love the record image, and on Chrome all is well. But on Internet Explorer and Firefox the music wont play. I have used both to preview the Theme Foundry and WP “shelf” demo and the initial record there also doesn’t play

    The blog I need help with is stirrupsomethingdivine.org.

    #29879

    scottrrollo
    Theme Author

    Hi there!

    You’re right; the first two audio files on your site are not working, but the David Crowder saying hello… audio file is.

    Could you please let me know what file format you’re trying to use?

    #29880

    dshrumm
    Member

    thanks for the speedy reply!
    I am using MP3s. If you look two posts to the right “equipment for getting stirred” and scroll down you will see that the small player seems to work correctly…the arrow plays a MP3 sample (although sometimes this is fishy in IE too…the clickable link is posted instead).

    But on my dashboard when I choose Audio under the lower right menu for type of post so that the 45 image shows with sound sample embedded this works only on Chrome.

    #29932

    tollmanz
    Member

    Hi there!

    Is it possible for you to link us to the MP3 that is having issues? It may just be a problem with the particular file.

    #29935

    dshrumm
    Member

    See if you can get IE or firefox to play this.
    (And have you had any luck getting them to play the Shelf live demo 45? I find this telling as well…)

    http://stirrupsomethingdivine.files.wordpress.com/2013/05/15-glorious-day.mp3

    #29952

    scottrrollo
    Theme Author

    Hi again,

    I can play this audio file in Firefox for Mac. Are you having issues in Firefox for PC?

    Could you please re-upload this audio file to a new post on your site? It’s possible the audio file currently on your site didn’t upload correctly.

    #29979

    dshrumm
    Member

    Hey! good news: IE reads the new upload fine. You must have been correct about a faulty upload

    So now it is just Firefox (on my PCs) that both 1) will not play but will only try to download the Fire and Rain new mp3 (the shelf yellow 45 record) and 2) won’t play the other posts samples (the arrow) used when the post is not “audio” but “standard” format.

    #29981

    tollmanz
    Member

    Hi there!

    Is Flash installed in your version of Firefox? Firefox will need Flash to play the audio.

    #29995

    dshrumm
    Member

    Flash helped Firefox. Thanks.
    Still, here is the Shelf Demo:
    http://shelfdemo.wordpress.com/
    IE won’t play it correctly, actually at all – the 45 player features a play arrow in front of the record with volume control and slider to tell where you are in sample. Instead, on my posts all that is displayed is the player used on standard posts. (see inserts on previous posts)
    Chrome shows a nice difference between players. My ipad does not, so maybe this is just something to live with, but I am surprised that 70% of browsers (IE) cannot play the shelf demo or “audio” formatted posts (rather than “standard”) as they were designed.

    #29997

    scottrrollo
    Theme Author

    Hi dshrumm!

    Thanks for helping us work through this issue.

    Which version of Internet Explorer are you using? We support versions 9 and above.

    #30006

    dshrumm
    Member

    IE 10

    #30012

    tollmanz
    Member

    As Scott said, thanks for helping with this issue!

    Can you tell me if the audio works on this site: http://demo.thethemefoundry.com/shelf-theme/. The problem might be due to an issue with the theme on WordPress.com and this would help confirm that suspicion.

    Thanks!

    #30014

    dshrumm
    Member

    nope. IE doesn’t play the demo at the themefoundry properly either. That is, the record appears with no player underneath. works fine with Google Chrome…

    #30015

    tollmanz
    Member

    Hi dshrumm,

    I have a logged a ticket and we will be taking a close look at this issue. Thank you for your help with debugging the issue.

    I will update this thread when I have more information for you.

The topic ‘Audio player muted in IE and Firefox’ is closed to new replies.