All icons on mobile view are broken

  • Author
    Posts
  • #161059

    sipofteanet
    Member

    Hi,
    Our icons are displayed perfectly fine on desktop view. However, all Menu/ Search/ Social Media icons are broken on mobile view. Please help check and support.

    Thanks.

    The blog I need help with is sipoftea.net.

    #161060

    babbardel
    Theme Author

    Hi!

    I noticed that your site is loading through HTTP and not HTTPS – can you ask your hosting to enable the HTTPS?

    #161072

    sipofteanet
    Member

    Hi,
    I’m not sure if there is any misunderstanding, but I think my site is loading in https now.
    https://imgur.com/cmRv7tV

    #161078

    babbardel
    Theme Author

    It looks like the site is indeed loading through HTTPS, but some resources are still called through the simple HTTP.

    The actual error looks like this:

    
    Mixed Content: The page at 'https://sipoftea.net/' was loaded over HTTPS but requested an insecure font 'http://sipoftea.net/wp-content/themes/patch/assets/fonts/fontawesome-webfont.woff2?v=4.3.0'. This request has been blocked; the content must be served over HTTPS.
    

    Can you check if you have any caching plugins (eg. Hummingbird) and try to reset/clear the cache?

    #161081

    sipofteanet
    Member

    It worked now. I actually used the “SSL Mixed Content Fix” plugin to fix this as clearing cache didn’t work. Thanks for your support.

    #161082

    babbardel
    Theme Author

    You’re welcome, and thanks for letting us know about the fix. Cheers!

The topic ‘All icons on mobile view are broken’ is closed to new replies.